Jump to content
Corsair Community

Possible bad Twin-X modules


Recommended Posts



I purchased about 5 days ago a brand new pair of Dual Channel Corsair Twin-X 1Gb DDR500 modules, I am already running on a pair of OCZ Gold VX 512mb DDR500, but whenever I add the new modules, the BIOS does not load.


I tried many configurations of RAM, including both twin-x alone and separate, but I get the same error, however, the older RAM works every time.


I have asked around, and have been told that I might have gotten defective modules.


my mobo does support up to 4Gb, so it ain't that


I would really appreciate any help you guys might give me since I was really looking forward to my 3Gb or RAM!


thanks in advance.

Link to comment
Share on other sites

ok, I did that, I tried all with factory settings, all timings on auto, voltages on standard setting, and still same problem, I only used the twin-x on this, not the older ones.


edit, update: I tried again today, I reset the BIOS, updated it and did all I could think of to it, but still no luck when it came to using the Twin-X.


would it make a difference to test it on another computer?

Link to comment
Share on other sites

well, Actually I received a suggestion to update my BIOS and change my timings in my MB to 3-4-4-8 and not set them on auto, and to set the vRAM at 2.7v


Im running at DDR400, 200Mhz 1:1 FSB rate, processor is at stock 200x11, 2.2Ghz


my old modules are rinnung at 2-2-2-6 at 3v, 200mhz DDR400


But again, I cannot modify anything while the Twin-Xs are in place, since I don't even get to the BIOS.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...