Jump to content
Corsair Community

Memory failed


Recommended Posts

I have a matching pair of Corsair TwinX Platinum Series (each are 1Gb modules) I bought them back in Jan 06 and they have been working fine till tonight. Suddenly my computer froze, I tried to reboot and starting having problems. I tried several things then I thought maybe the memory, so I removed one module and the system booted fine! I then removed that module and replaced it with the other and I could not boot. After the post screen I would see windows start to boot then I would get errors and sometimes the machine would just start to reboot over and over. I took that module out and replaced it with the other and no problems booting or running any programs. I even tried it in my other computer and after removing all of the memory in that machine and putting the suspect module in, same kind of problems.. I believe I have a bad module. Please instruct me what to do next.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...