Jump to content
Corsair Community

1 GB Flash Voyage, slow write speeds for small files


jjack229

Recommended Posts

I received a replacement for my previous 1GB Voyager two days ago. I plugged my new flash drive into my computer, it was recognized immediately, I transfered over a ~40 MB file, it worked fine.

 

So I made a Trillian and Winamp installation on my computer that I would transfer over to the flash drive (so that I can run those programs anywhere-as I had done on my previous flash drive). However, when I tried to copy the files over to my flash drive it took a very long time. (I verified this with a seperate computer-same problems). To give some numbers:

 

1 Zip 25 MB -> 8 sec

6 mp3's 26 MB -> 13 sec

Trillian (460 files) 26 MB -> 7 minutes

1 ISO 600 MB -> 2.5 min

 

I can understand that transfering many small files may take slightly longer, but 7 minutes seem rather extreme, especially when a 600 MB file is 2.5 min.

 

I performed a benchmark test on the flash drive by Sandra 2007 SP1:

 

http://stuweb.ee.mtu.edu/~apkunze/Temp/USB_Graph.jpg

 

It shows that for small files, my write speed is slower than USB1 drives.

 

I was wondering if this is simply a characteristics of the new 1GB Voyagers (my old one didn't have any such problems), or if I need to format my flash drive, or if it is defective (I would hope that I wouldn't already need to get a replacement for my replacement).

 

The problem of my previous Voyager (although I do not think that it is relevant):

 

http://stuweb.ee.mtu.edu/~apkunze/Temp/USB_Problems.txt

 

 

Thanks for any help,

 

Windows XP SP2

Pentium 4 2.53 GHz

Intel D865GBF motherboard

Link to comment
Share on other sites

I tried formatting the flash voyager using Corsair EZRecover, however it keeps saying "Please attach a device to do EZRecover" when my flash drive is plugged into my computer, even if I unplug it and plug it back in.

 

So, to format my drive I opened up My Computer and right-clicked on the flash drive and choose Format. The default is FAT32 and the format went fine.

 

After that I tried my flash drive and the write speeds were still very slow for small files. I was using it to transfer some files around for a few days when I plugged it into another computer and it did not see any of my files on the drive, though it did show that about 50 MB was used. I had the same issue in other computers including my own computer, so I reformatted it again yesterday.

 

Again the same slow write speeds for small files, I did an HD Tach test:

 

http://stuweb.ee.mtu.edu/~apkunze/Temp/USB_HDTach_Full.JPG

 

and another Sandra test:

 

http://stuweb.ee.mtu.edu/~apkunze/Temp/USB_Sandra_2.JPG

 

which again showed very low speeds for small files (smaller than USB1 drives)

 

So, I am wondering if I formatted it correctly, or if I should be doing it differently. And if the write speeds are 'normal' for the current 1GB Voyagers (as I never noticed this problem for my previous 1GB Voyager).

 

 

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...