Jump to content
Corsair Community

problems with a corsair flash voyager


ithalan

Recommended Posts

Hi

I am writing on behalf of my uncle who has bought a 128 MB flash voyager. He has been working with his device for about 6 months when he started to have problems with it. Like two weeks ago when he plugged his device to his PC running Win XP pro he got an error message asking to format it. He wanted to recover his very important information so we tried to read the USB on at least three PC’s before going to the format option. However, when finally trying to format it we got a message saying that the device could not be formatted because it was write protected. As suggested on many entries on this forum I also tried to format it using the Windows Device Manager and the EzRecover tool, but all I got was messages saying that the formatting couldn't be finished successfully.

 

Please advice what else can we do.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...