Jump to content
Corsair Community

Cant access drive


ron_r_08

Recommended Posts

I just got my flash drive today, I pluged it in and it installed. I went to My Computer but there was no icon for the flash drive. I restarted the computer and it didnt help. I tried that ezrecovery software that has been referenced in this forum a few times but it wont detect the drive. Then i went into device manager and I got an exclamation point next to the flash drive which stated:

 

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

 

I havent deleted anything or messed with the registry at all. I tried uninstalling and reinstalling it but got the same error message. I hope this problem can be resolved. Any info would be appreciated. Thank You.

Link to comment
Share on other sites

  • Corsair Employees

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

 

If you still have problems, let’s get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...