Jump to content
Corsair Community

1GB Flash Voyager not recognised - Registry Error


gravityfan

Recommended Posts

My Voyager 1GB works OK on some other machines, so I know it isn't faulty. However, on my XP PC, it is not recognised.

 

It does not get auto detected, so I run Add Hardware Wizard. The search fails. I select "Yes, I have already connected the hardware". The installed hardware list shows as the first line "Corsair Flash Voyager USB Device", but with the yellow circle exclamation mark. I highlight it and click Next. All I get is the message:

"Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"

 

I have in the past tried removing references to the devide in the Registry, but I guess there are problems that I cannot see.

 

Can I "fix" the Registry, or is there a utility that I can use?

Link to comment
Share on other sites

  • Corsair Employees
With the drive connected you have to go to Device manager and remove the Flash Drive and any other device with a ? or ! mark next to it then remove the drive and restart your system. And let windows install all of the drivers needed for the on board USB hub and controller. Then go to the MB maker’s web site and make sure that you have the latest chipset and USB drivers installed for your system as well as all of the Windows updates especially service pack 2. Then once all updates are done try and install the flash drive again and just let windows install the default drivers should be all you need to do. If you have problems or get stuck please call our Tech support. 800-205-7657!
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...