Jump to content
Corsair Community

CMFUSB2.0-1GB Bad?


sraz

Recommended Posts

One day, I plugged my flash drive into the computer. The next day I brought it over to another computer and get the wonderful "Drive is not formatted, would you like to format it now?" message. Well I went ahead and formatted it, luckily I had recently done a backup of all my data that was on there.

 

I was doing fine, was able to read and write files off the drive. No problem, at least I thought. When I unplugged it and brought it to work, I got the exact same message when I tried to access it there. I tried a couple more computers, but I still get the same message. I'm thinking it died on me...

Link to comment
Share on other sites

  • Corsair Employees

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

But First if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site.

If you still have problems, lets get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...