Jump to content
Corsair Community

FlashVoyager 2Gb "Not Formatted?"


wilyliam

Recommended Posts

Greetings,

Been using my FlashVoyager 2Gb for about a year now, with great success. Suddenly, everytime I plug it in, it gives me an error saying it's "Not Formatted" The drive appears in Explorer, is given a letter - but if I try to access it, it is "Unformatted."

 

Tried using the Corsair recovery application, but that made no difference. Ultimately, I reformatted the drive, and it worked for about a day, and then started with the same error. Also, sometimes when I plug it in, it is recognized by the system as some other brand of USB drive and reinstalled - still comes up "unformatted" however.

 

Thanks,

Will Sauve

Link to comment
Share on other sites

  • Corsair Employees

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

But First if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site.

If you still have problems, lets get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...