Jump to content
Corsair Community

MemTest errors with TWINX2048-3200C2


Blimp

Recommended Posts

Hi!

 

I have a problem to get the TWINX2048 to work with my overclocked Opteron. First for the involved hardware:

 

Specs:

TWINX2048-3200C2 XMS3202v2.1 Lot# 0610060-1

DFI LANparty UT NF4 SLI-DR Expert (BIOS 12/7/2005)

AMD Opteron 165

 

With FSB set to stock values the RAM is stable with the timing 2-3-3-6-1T @ 2.74v as recommended by corsair. (http://www.corsair.com/corsair/products/specs/twinx2048-3200c2.pdf)

25x test #5 of MemTest without an error.

 

But when I set the FSB to 290 to overclock the Opty to 2600MHz the RAM want work neither with a divider of 7/10 nor with 2/3. (permanent reboot)

Only with a divider of 1/2 it will boot to WinXP.

 

Am I missing something?

thx in advance for your help!

 

edit: Forgot to mention that dropping the timing 3-3-3-8-2T want change anything.

Link to comment
Share on other sites

I don't know if I got things right.

 

Can anyone tell me the difference (for the RAM) between for instance

FSB 200

divider 1/1

and

FSB 266

div 3/4

or

FSB 285

div 7/10

??

 

I thought as long as the divider is set correct the FSB doesn't matter for the RAM.

Link to comment
Share on other sites

Forget my last posts, the RAM don't even run with the recommended timings at stock values.

 

At the first test (stated as "25x test #5 of MemTest without an error" in my first post) the CPU/FSB was set to 7x and the LDT/FSB was set to 2.5x because I thought they only affect the CPU and not the RAM test. The plan was to exlude CPU faults from the RAM test. My fault.

Now with CPU/FSB and LDT/FSB also set to the stock values (9x, 5x) I get lots of #5 errors.

Timing is like recommended 2-3-3-6-1T @ 2.74v.

Raising to 2.8v (as advised in other threads here) didn't change anything.

 

What to do now?

Link to comment
Share on other sites

Hi!

 

As I postet in the Enthusiasts Only section, MemTest shows a lot of errors at testcase #5 when I try to run the memory at recommended timings and volts.

(see attachment)

 

I'm using

TWINX2048-3200C2 XMS3202v2.1 Lot# 0610060-1

DFI LANparty UT NF4 SLI-DR Expert (BIOS 12/7/2005)

AMD Opteron 165

 

Settings are

FSB 200

divider 1/1

timings 2-3-3-6-1T @ 1.74v

 

What's wrong? :confused:

Thx in advance for any help!

432578750_error5.jpg.a09527243527e0d8cd787d971e3bec0a.jpg

Link to comment
Share on other sites

I had not much time to test at the easter weekend, family stuff and so on, you know.

Here are the results so far:

(I marked one of the RAM sticks to be able to identify them so S1 and S2 are indeed the specific sticks)

 

test |   ChannelA  |   ChannelB  |     | errors after | 
case | DDR1 | DDR2 | DDR3 | DDR4 | CPC | 1 hour of #5 | notes
-----+------+------+------+------+-----+--------------+-------------------
1   |  --  |  S1  |  --  |  S2  |  1  |     8192     |
2   |  --  |  S1  |  --  |  S2  |  2  |     1214     |
3   |  --  |  S2  |  --  |  S1  |  1  |     4        |
4   |  --  |  S2  |  --  |  S1  |  2  |     0        |
5   |  --  |  S1  |  --  |  --  |  1  |     0        | 
6   |  --  |  S2  |  --  |  --  |  1  |     0        | 
7   |  S1  |  --  |  --  |  --  |  1  |              | doesn't boot
8   |  S1  |  --  |  --  |  --  |  2  |              | doesn't boot
9   |  S2  |  --  |  --  |  --  |  1  |              | doesn't boot
10   |  S2  |  --  |  --  |  --  |  2  |              | doesn't boot
11   |  S1  |  --  |  S2  |  --  |  1  |              | doesn't boot
12   |  S1  |  --  |  S2  |  --  |  2  |              | doesn't boot
13   |  S2  |  --  |  S1  |  --  |  1  |              | doesn't boot
14   |  S2  |  --  |  S1  |  --  |  2  |              | doesn't boot

 

Settings were FSB 200, divider 1/1, timings 2-3-3-6, voltage 1.74v.

 

I think testcases 5 and 6 looks like the board is broken because each of the sticks works fine in DDR2. What I don't understand is the fact that the combination in testcase 3 is more stable than the one in testcase 1.

 

I will run more testcases when at home, especially testing slots DDR1 and DDR3.

In addition I eventually will get some 512MB Single Channel sticks so I will try them too.

 

What do you think is enough testing to be sure the board is broken?

 

(I will edit this post to keep the results of the testcases updated.)

 

edit. testcase 7 to 14 added

Link to comment
Share on other sites

  • Corsair Employees

Maybe you understand what you have posted but it does not make sence to me sorry! You are trying to run these modules at 290 MHz? if so thats not what they are rated at. I would suggest testing the systemn not over clocked and set the memory to the tested settings as listed in my signature.

 

Command Rate is not really a memory setting and would be dependant on the make and model of MB and PSU and the specific CPU you have installed. You might look this setting up on http://www.rojakpot.com and get a better explanation.

 

You should be testing the system with these settings for reference.

CPU Freq: 200 MHz

System Performance: User Define

Memory Frequency: 100%

Dim Voltage to 2.7 Volts

Resulting Frequency: 200MHz/DDR400

Memory Timings: Manual/User Define

SDRAM CAS Latency: 2T

SDRAM RAS to CAS Delay (tRCD): 3T

SDRAM Row Precharge (tRP): 3T

SDRAM Active to Precharge Delay (tRAS): 6T

All other settings should be left at Bios default or AUTO.

Link to comment
Share on other sites

Sorry for beeing .... that cryptical. :-(

I changed the chart to hopefully be more clear (removed the notes).

Forget about the mystical 290 thingy for now. I tried to explain it at the bottom of this post for complemental reasons, but its not essential for the real problem.

 

I did exactly what you expect me to do.

 

I Used the following settings for all tests:

FSB is 200MHz

Memory Frequency is set to 100% (as the FSB/RAM divider is set to 01/01)

Dim voltage is set to 2.74 (as recommended at the products pdf, but it makes no difference, same results for 2.7 volt)

so memory is tested with 200MHz (200 * 1/1)

CAS is set to 2T

tRCD is set to 3T

tRP is set to 3T

tRAS is set to 6T

All other settings are set to auto (except CPC which is set to the value written in the CPC column of the graph)

 

The "chart" just shows the different combinations I tested.

Just to clear out misunderstandings about the columns of the "graph" (skip this passage if columns are clear):

The column testcase is just a sequential number to identify the different combinations of which-stick-in-which-slot-with-which-value-for-CPC, to make it easier when talking about a specific test.

DDR1 to DDR4 are the 4 slots

CPC is the value of the Command Rate because I tested both, 1T and 2T (as you told me to do in post #5)

S1 is stick #1 and S2 is stick #2

The errors column shows how many errors occured while running test #5 of MemTest86 for about an hour.

 

So any single stick in slot 2 didn't show up any error (testcases 5 and 6) while other combinations show up errors.

This leads me to the assumption that the RAM is okay and at least the RAM slots of the board are somewhat unstable.

 

Anyway, I did some more testing:

I tried slot 1 and 3 with either a single and both sticks put in and in every single case the rig doesn't boot.

So I took the RAM of my old PC (2x256MB Single Channel sticks by Infineon) and put it into slot 1 and 3 -> system doesn't boot.

 

For me it seems like the problem has nothing to do with the TWINX sticks which also worked fine when I tried them in my old PC.

I think the board is somewhat unstable (at least the RAM slots) and plan to RMA it.

Is there any other possibility, than a broken board, which would cause this behaviour? (Just to be sure the board is responsible for the errors before RMA it)

 

 

 

 

Now for the misunderstandings about the FSB of 290MHz:

The Opterons FSB/CPU multiplier is stuck to 9x. To run the CPU at a higher rate, you have to raise the FSB.

While playing around with the FSB you, of course, have to take care about the RAM so you have to set the FSB/RAM divider in the BIOS to 1/2.

Therefor the RAM is out of danger for a FSB up to 400 (400 * 1/2=200MHz). A FSB of 400 anyway is far beyond you will go while overclocking so a FSB/RAM divider of 1/2 will keep the RAM between 100 MHz (FSB 200 * 1/2) and 200 MHz (FSB 400 * 1/2).

My CPU maxed out at 2610MHz so because of the stucked FSB/CPU multiplier of 9 I have to raise the FSB to 290 to get the 2610 MHz on the CPU. But at the same time I have to select a FSB/RAM divider to get close as possible but don't exceed the 200MHz of the RAM. This is done by setting the divider to 7/10 so 290MHz * 7/10 = 203MHz

or setting the divider to 2/3 so 290MHz * 2/3 = 193MHz.

 

Because the RAM worked fine in testcase 5 and 6 at stock values I did some additional test with the BIOS settings set to the values of the overclocked CPU with the FSB set to 290 and the FSB/RAM divider set to 7/10. And the RAM still worked fine. Thats what the notes stands for.

 

 

 

I hope this clears some things up.

I'm very very sorry and please excuse my bad english which maybe makes things more difficult to understand. :-(

Link to comment
Share on other sites

  • Corsair Employees
All these settings will not matter if the modules will not pass at defaults settings for your CPU, and if they pass when the CPU is not over clocked, but not when you are over clocking that would suggest maybe the Over clock is too much for your configuration. I would not suggest wasting time testing with a divider setting as that would not warrant replacing the modules. In fact based on what you have posted I would encourage you to try another MB based on what you have posted so far.
Link to comment
Share on other sites

Thats clear (to test with default settings first), the problem is, they failed most of the tests at default values too.

 

However.

Today I went to the shop where I bought the MoBo and told them about the problems about booting and memory errors with the board.

The guy at the shop did some testing with the MoBo and confirmed the reported problems. He too couldn't get the board to boot with some stick-slot combinations. So I went home with a new MoBo.

 

Back at home putting things together, I put the RAM into the same slots I had them originally in the old MoBo (the orange slots as recommended by DFI).

Of course the first thing I wanted to know was how MemTest will do with the new MoBo.

The only thing I changed in the BIOS was to raise Dimm voltage to 2.74v and setting the timings manually to 2-3-3-6-1T because SPD would set them to 3-4-4-8 afaik.

 

Half an hour of MemSet test #5 showed 656 errors.

I then changed the CPC to 2T (as you told me a few days ago).

126 errors

 

I know I should do some more tests like single sticks, sticks in other slots and so on, but again its past midnight here and I'm very very tired from testing night after night only to see red errors on the screen. So I will do more tests tomorrow if I hadn't thrown in the towel till then.

 

however, thx so far for your efforts and patience RAM GUY. see ya tomorrow

Link to comment
Share on other sites

  • Corsair Employees

Can you tell me the exact settings you have set for CPU and memory? And here are some settings I would try after you load setup defaults with the modules in the yellow slots.

Genie BIOS/DRAM Configuration

 

DRAM Frequency Set: 2:1 or 400MHz or 200 (if option are 133/166/200)

Command per Clock: Enabled

SDRAM CAS Latency: 2T

SDRAM RAS to CAS Delay (tRCD): 3T

SDRAM Row Precharge (tRP): 3T

SDRAM Active to Precharge Delay (tRAS): 6T

And leave the rest at AUTO setting

Genie BIOS

FSB BUS Frequency: 200

LDT/FSB Frequency ratio: 5X

LDT Bus Transfer Width: 16 16

CPU/FSB Frequency ratio: Auto

PCI Ex: 100

K8 cool N’ quiet: Disable

CPU VID Start Up Value: 1.55 (Depends on CPU Core)

CPU VID Control: 1.55 (Depends on CPU Core)

CPU VID Special Control: Auto

Chipset Voltage Control: 1.6

DRAM Voltage Control: 2.7

All other settings are motherboards defaults

Then please test them one at a time with http://www.memtest.org and let’s make sure it's not some other issue! I would run the test for at least 2-3 passes to be sure!

Link to comment
Share on other sites

The attachements show the settings for yesterdays tests.

 

I just tried the settings you recommended (modules in the yellow slots) and I not even can get to the BIOS, exactly the same behaviour like with the old board.

 

Now again I'm absolutely confused :confused:.

Was the board I returned to the shop on Tuesday okay? (But if so, why had the guy in the shop also problems to boot?)

Has the new board exaclty the same problem as the old one? (How possible would that be?)

Is it possible, that the CPU is faulty?

Am I too stupid to get this thing to work? Of course I would deny that one.

 

Because I can't get to the BIOS when the modules are in the yellow slots, I just tried to put one of them in a orange slot, bootet to BIOS, loaded defaults, changed the settings according to your last post, put the modules back into the yellow slots and rebootet.

Same thing, the fans start turning and all three status LEDs of the board are lit, and nothing happens.

826458963_Corsair001.jpg.b27c9239abf6ef41ea4d52176fb2c7e8.jpg

1950510747_Corsair002.jpg.b5b64f80fe84f67f10508cf659331412.jpg

39038868_Corsair003.jpg.25f1bf8d62366aac41955937390c1073.jpg

Link to comment
Share on other sites

  • 2 weeks later...

FYI:

 

I sent in the parts on 24th of April.

 

After that I did some more testing with 2 other types of RAM modules I got. (2x512MB by Infineon and 2x256MB also by Infineon)

It turned out that I had the same problems with any of these.

 

To tell a long story short, I changed the DFI-Expert to a Asus A8N-Sli Premium.

Just wanted you to know in case it makes a difference in your testing of the modules.

Link to comment
Share on other sites

  • 2 weeks later...

I've got the new modules yesterday but had not much time for testing.

What I got so far doesn't look very good. :(

 

Modules are in slot 1 & 3

 

2-3-3-6-1T @ 1.75v

gives the same errors in MemTest at test #5

same thing with

2-3-3-6-2T @ 1.75v

 

So, 3 boards and 4 different RAMs (of testing) later I'm kinda puzzled.

As I mentioned a while ago, is it possible that the memory controller is faulty/unstable?

 

I will do more testing in the evening.

Link to comment
Share on other sites

Modules in slots 2 & 4 and yehaw, 2-3-3-6-1T gives me no more errors with MemTest (at an RAM bandwith of 2019 MB/s).

Using slot 2 & 4 is against the recommendation of the boards manufacturer but who cares, as long as it runs now.

 

Later in the evening I encountered another oddity with the RAM settings while OCing my CPU, but thats something for the Enthusiasts Only and not the Warranty subforum.

 

Finally I have to say thank you very very much to all of you beeing involved.

Impressive support!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...