Jump to content
Corsair Community

Flash Voyager gone bad


nin

Recommended Posts

Hi,

 

I've had this flash voyager for over a year now & yesterday I tried to use it & it is repeatedly saying it needs formatting.

Also sometimes when I plug it in it detects as a Prolific USB device or 0000000000000, rather than Corsair Voyager.

I have formatted it a few times now & tried saving new data on it, but it just doesn't want to know anymore. It either tells me it's write protected or if I do get to write to it, the data vanishes next time I insert it.

 

I have bought a another voyager (128MB version) which is working fine, so this proves there is nothing wrong with the USB or settings on my computer.

 

Is there anything else to check or can I RMA it?

Link to comment
Share on other sites

  • Corsair Employees

Please try and format your Flash Voyager with Corsair EZ-Recover Utility. Please note; this will not recover Data; it’s made to recover the FAT table for the Flash drive.

But First if you need to recover some data there are some third party utilities available that may help you if you have some data you need to recover from this site.

If you still have problems, lets get it replaced. Please use the RMA request found in TSXpress or follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...