Jump to content
Corsair Community

Flash Voyager and "Generic USB Hub"


Recommended Posts

Hi folks...my first post here. (And I apologise for the length, I just want to be clear).


I just bought a 1GB Flash Voyager and really like it a lot. (I have a collection of Thumb Drives, but this is my first Corsair).


I am running XP Pro, SP2.

I noticed while first installing the drive (and later from the manual), that "the Flash Voyager uses an embedded generic usb hub".


Down in my system tray, I could see it installing "the Generic Hub", the "Mass storage device", and the Flash Voyager when I inserted it the first time. (Everything installed fine and the drive is working great...I haven't bothered with the utilities- yet)


Anyway, now here is the strange thing.

On this particular computer, I had already installed a powered front panel USB 2.0 hub (it's powered from a 5v floppy connector off my psu) which is connected internally to a USB 2.0 PCI card.

Works pretty slick actually. :):


This Hub comes up in device manager as....you guessed it, a "Generic USB Hub". (IE, it was there even before I installed the Flash Voyager).


I should mention that I have the "device connect" and "device disconnect" .wav sounds enabled in my windows sounds, because I like to hear USB devices connecting and disconnecting etc.


Now, when I plug in my Flash Voyager, there is a quick double sound (almost like two devices are connecting). All my other Thumb Drives only have one "connect .wav" sound.


Furthermore, when I safely disconnect the Drive, I hear the usual "device disconnect" sound (a single one), and then perhaps a minute later, a second device disconnect sound.


I'm wondering if there is some sort of possible conflict between my Front Panel "generic USB Hub" and the "embedded generic usb hub" that is part of the Flash Voyager.


In any event, I can't imagine what is disconnecting a minute later after I unplug the Drive, and causing the second .wav sound.


Any thoughts???


(EDIT) I added this because I just noticed when the Voyager is connected, there are in fact TWO entries for a "generic USB Hub" in Device manager. (The one that was always there from my front panel hub, and apparently a second entry the Drive adds when inserted).


I also just monitored Device Manager, and when I safely remove the Flash Drive, the "Mass Storage device", and the additional "Generic Hub" entry disappear right away, but I still get the second disconnect sound a minute later.



Guess I'm nit picking here since it seems to be working ok, but I hate mysteries.

(And I'm also a little concerned that what ever this "mystery device" is that remains connected for an extra minute, may cause a problem down the road (slowdowns etc), until it "officially" disconnects.


(EDIT #2) Sorry the make this post even longer, but I just tried the drive on a different Computer of mine (WITHOUT a front panel Hub), and I still get the "delayed" disconnect sound, so I guess this is not related to the existing hub.


What the heck could be disconnecting a minute later???

A couple of times, the second disconnect sound has even come as much as two or three minutes later....after I had forgotten all about it.


Anyone else ever have this happen? (Providing of course you have the .wav sounds enabled, or you wouldn't know it was happening I suppose).


Thanks in advance for any thoughts or comments.

Man! I sure hope all of that made some sense!

Link to comment
Share on other sites

  • Corsair Employees
You are connecting the flash drive thru a second Hub that is why you are seeing the hub listed and that is normal. Even if you use a USB extension that came with the MB you may get the same Generic USB HUB, it may install it as a second HUB. That’s normal and as long as it’s working with no problem you should be fine.
Link to comment
Share on other sites

Thank you for the reply RAM GUY

Yes, most of my computers are a little older and have USB 2.0 PCI cards installed in them (Some in the form of front panel USB Hubs).


As you said, everything appears to be working fine.

However, do you have any theories as to why I get the delayed (sometimes delayed up to 2 or 3 minutes), "device Disconnect" .wav sound?


This second delayed "device disconnect" .wav sound makes me wonder what may still be connected well after I've removed the Flash Drive.


This actually bugs me more than the Hub entry. (The additional Hub entry and the "Mass storage device" disappear immediately as soon as I remove the Drive if I monitor it in device manager, just as they should).


But this Voyager is the ONLY Drive I own that produces not only two rapid "device connect" sounds when I insert it, but two "disconnect .wav" sounds after I remove the drive as well.


(Like I said, one sound immediately, and one sometimes several minutes later)


What could this be do you suppose that is still possibly "connected" for a while after the drive is removed?

(And sorry to be a pest).

Link to comment
Share on other sites

Ok....thanks again for the reply.

I appreciate it.


My System is completely updated, but I'll ask around a little more and see what I can find, or I'll just stop worrying about it and use the darn thing.


Heheh...thanks again.

Link to comment
Share on other sites

Well, amazingly, I've found three other people that own this drive and experience the same "double" device connect sound, and the second "delayed" device disconnect sound.


Doesn't matter if they use a Hub or plug it directly into their on-board USB 2.0 Port.


Last night, I heard the second Device Disconnect .wav sound a full four minutes after I removed the drive.


I'm afraid however, that this is just one of those mysteries that won't ever be be solved.

At the same time, I'm totally amazed that nobody here in the Official Corsair Forums has ever mentioned or experienced this before.


One guy I spoke to never knew it because he always has his speakers turned down low, and another never had the windows "Device Connect" and Device Disconnect" .wav sounds enabled in Windows Sounds.

He heard the second sound two minutes after removing the drive.


As I mentioned, it doesn't seem to effect performance, but surely there is an explanation as to why this is the only Drive I own (out of 7 different models), where something remains connected for so long after the drive is removed.


Guess I'll never know, but I sure wish Corsair knew what it was.

Again, I'm just astounded that I found three people in one day, but nobody here has ever heard of it before....strange.


Oh well, I'll attempt to forget about it now. (Not easy if you're me). :sigh!:


At the same time, whenever I use it, I'll always be waiting and wondering when that final disconnect sound will come, so I'll know the device is truly removed from the system.


It may be enough to eventually cause me to sell what otherwise would be one of my all time favorite Flash Drives.


Don't mine me folks...just my OCD kicking in again. :laughing:

Link to comment
Share on other sites

  • Corsair Employees
I dont think its a problem with the drive, but I have no problem replacing it. This is comming from the driver thats installed by windows and more than likely its software related, but if you want to try and have your drive replaced, please use the On Line RMA Request Form and we will be happy to replace them or it.
Link to comment
Share on other sites

Thank you very much RAM GUY


I agree, I don't believe it's a problem with the Drive either. (Especially since I have found other people that experience the same strange quirk, but they don't let it bother them like I do). :sigh!:


I'll hang on to it since it seems to be working great other than this "delayed disconnect" sound.


I must say- Your offer to replace the Drive with so little hassle is very refreshing and appreciated. (And rare these days!)


If I have any other problems, I'll be sure to check in here....in the mean time, I'll keep using it.

Again, I sincerely appreciate your help.

Link to comment
Share on other sites

  • Corsair Employees
No problem, please let me know if you resolve the issue thou if you don’t mind. But I suspect that doing a fresh install of the O.S. and using the latest bios and drivers may solve the problem. However, there is no way to know for sure till you so it. Also if you have any Antivirus or Disk utility software installed you might disable it and see if that makes a difference. For example Norton Utilities or Norton Antivirus.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...