Jump to content
Corsair Community

USB 2.0 stop working!


Recommended Posts

Hello all,


I have a CorsairFlashVoyager 1Gb.


Until yesterday it was working fine.


Today, each time I plug in my laptop, I get the message saying that this device could be connected to a high speed port and it works as low speed (USB 1.1)


I tryied in other PC with high speed USB port (2.0) enable, getting the same result!


It could be possible that my flash memory is damage? How can I know if it is all fine with it?





Link to comment
Share on other sites

HI everyone,


I've also just started getting this problem as well - 2Gb Flash Voyager - worked perfectly for the last 3 months or so and then last week started getting the 'this device will work faster if connected to a hi-speed...' - this happens on any computer I connect it to


I'm in the UK and I purchased through dabs.com


IS there any way I can get this returned?


All the best and thanks for any help





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...