Jump to content
Corsair Community

Troublesome TWINX sticks


Recommended Posts

I bought a set of TWINX-3200C2PT (total of 1g) sticks from Fry's in the end of Nov 2004. I was actually building a new base system and was going to use some of my old parts (HDD and case). A friend told me I paid too much for the card I bought and could get it on the net for half the price, so I took it back that night. I didn't get to putting the rest of the system together for a couple of weeks. I put the system together, but never powered it on because of the missing video card. I put off the system again, and then due to work reasons and moving a couple times, I landed up putting the system in my storage unit till things settled.


The system sat there till this past December. I put an old GeForce 2 in there so I could at least install the system.

When I turned on the system, it just would beep, pause, beep over and over till I turned it off. I switched the mem sticks positions and tried again. This time it would just turn on. Fans and everything else were on, but the screen would never turn on. For a second, I thought that the MB had a weird setup, in which the slots were ordered ChannelA,ChannelA,ChannelB,ChannelB. I put ram #2 into the DIMM3 slot (#1 being in DIMM1). It finally booted. So I began installing Linux (Gentoo). We I untarred the stage3 tarball, during the middle of untarring, the system froze. It did this several times. I decided to install XP. During the first bootup of the install disc, it locked up. I couldn't figure it out. I did notice that it locked up after loading the FAT driver, so I thought maybe my 20gig drive was bad. I took it out and planned to install on my other HDD. Still locked up. I decided to take one of the DIMMs out. I landed up taking one out one and moving the other from DIMM3 to DIMM1. This time XP loaded up to the installation screen. However, it locked up before I could start the install.


I managed to make a UBCD and ran memtest86. A lot of errors scrolled by before the system locked up again. When I tested, I had both sticks in (but not in Dual Channel mode ..DIMM1 & DIMM3). I noticed that memtest86 said that the memory was at 166Mhz (DDR333) with CAS showing 3-3-3-7. When I tested one stick, it showed 200Mhz DDR400. One stick had errors around 240megs and the other had errors around 505megs. When I changed the ram voltage to 2.70, it wouldn't even boot with one stick in. I swapped sticks, and it would boot. With one stick in, it showed CAS with 3-3-3-8. There are only three settings to change in the BIOS for the mem, two were set on auto while the other was just to limit the speed of the ram (set to 200Mhz).


I have no clue what's up with these things.

On the stick:

CMX512-3200C2PT XMS3202v4.1


XMS3200 512MB 400Mhz CL2



After seeing what memtest86 spat out, I'm guessing these are bad.

Would I be able to go to Fry's and have them swapped for good ones, or do I have to go the RMA route?


Thanks in advance, and sorry for the long post.




Link to comment
Share on other sites

Well, the flash seems to have worked. It'll boot up with both DIMMs in dual channel mode. I'm going to try installing an OS. If this turns out to have worked, I'll be glad. That'll save me some money. Kinda lame though to think these boards are like this from the factory.

BTW, after clearing CMOS, bios showed 200Mhz, 2.5 Tcl, 8T Tras, 4T Trcd, 2T Trp, 2T Trrd. There's a lot more settings to tweak in the bios for the mem after the bios flash.


Hope someone finds this useful. :\


I'll post back on whether the OS install goes well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...