Jump to content
Corsair Community

Flash Voyager unstable?


Recommended Posts


I've read the RMA page to send my FlashVoyager 512Mb to testing and it says I have to come here and post a thread before sending anything.

Here's my case.

I have a FlashVoyager 512Mb and used it for about 6 months to carry data between my office PC and my home PC. Both are XP Pro. One day, I connected the drive to the USB at home, and windows detected it (as usual) but suddenly it was showed as removed (2 seconds after), and again was detected as connected. Until I removed the drive from the USB, windows kept detecting and "undetecting" it. Testing on my office PC, it happens the same problem. At home a also have an older system with Windows 2000 and an older USB and it works fine there. In my office I also have a Windows 2000 but on a newer system and it doesn't work there.

My conclusion (if I may) is that on older usb (like 1.1?) it works better, but on usb2 it happens the same on every system; windows detects it and two seconds after it is undetected and so on, until I disconect the drive from the USB.


Well, I hope you could understand the problem, since my english is a little poor.



Andrés "kavesa" Araujo

Link to comment
Share on other sites

I had the same stability problem two days ago with my 512MB drive, when I installed a USB2 adaptor on my notebook. It worked fine on my built-in USB port, but the port is USB1. Yesterday, the drive suddenly quit on all computers I tried: the computers detected the drive, but couldn't access it, showing "I/O device error" message. I wonder if the USB drive is dead.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...