Jump to content
Corsair Community

bad module, but no errors detected in memtest

Recommended Posts



I got a Corsair CMX512-3000C2 (2x512Mb, dual channel, 400mhz). The pair ran well for about 2 month, but then errors sporadically began to occur. My OS is gentoo linux, so I often compile and install packages. The system freezed and strange "kernel-bugs" occured.



Oct 1 17:30:13 hermes ----------- [cut here ] --------- [please bite here ] ---------

Oct 1 17:30:13 hermes Kernel BUG at "mm/page_alloc.c":415

Oct 1 17:30:13 hermes invalid operand: 0000 [1]

Oct 1 17:30:13 hermes CPU 0

Oct 1 17:30:13 hermes Modules linked in: snd_seq_midi snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq

_midi_emul snd_pcm_oss snd_mixer_oss snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_emu10k1 snd_rawmi

di snd_seq_device snd_ac97_codec snd_pcm snd_timer snd_page_alloc snd_util_mem snd_hwdep snd soundcore isofs zl

ib_inflate parport_pc parport 8250_pnp 8250 serial_core floppy i2c_viapro i2c_core nvidia

Oct 1 17:30:13 hermes Pid: 18872, comm: cc1plus Tainted: P 2.6.13-gentoo-r2

Oct 1 17:30:13 hermes RIP: 0010:[<ffffffff80154ecf>] <ffffffff80154ecf>{__rmqueue+191}

Oct 1 17:30:13 hermes RSP: 0000:ffff810017e11c98 EFLAGS: 00010002

Oct 1 17:30:13 hermes RAX: 0000000000000001 RBX: ffffffff803c0a00 RCX: 0000000000001000

Oct 1 17:30:13 hermes RDX: 4924924945bd7946 RSI: ffff810742728750 RDI: ffffffff803c8488

Oct 1 17:30:13 hermes RBP: ffff810742728750 R08: 0000000000000001 R09: 0000000000000001

Oct 1 17:30:13 hermes R10: 0000000000000001 R11: 0000000000000000 R12: 0000000000000001

Oct 1 17:30:13 hermes R13: 0000000000000001 R14: ffffffff803c8488 R15: ffff8100017b6bd0

Oct 1 17:30:13 hermes FS: 00002aaaaaff36d0(0000) GS:ffffffff8047c800(0000) knlGS:00000000560e9830

Oct 1 17:30:13 hermes CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033

Oct 1 17:30:13 hermes CR2: 00002aaaad417000 CR3: 000000000b589000 CR4: 00000000000006e0

Oct 1 17:30:13 hermes Process cc1plus (pid: 18872, threadinfo ffff810017e10000, task ffff81001ddb20b0)

Oct 1 17:30:13 hermes Stack: 0000000003b0e708 ffffffff803c8488 ffffffff803c84d0 0000000000000000

Oct 1 17:30:13 hermes ffffffff803c84c0 0000000000000000 0000000000000000 ffffffff8015528c

Oct 1 17:30:13 hermes 0000000000000000 000000000000001f

Oct 1 17:30:13 hermes Call Trace:<ffffffff8015528c>{buffered_rmqueue+124} <ffffffff80155673>{__alloc_pages+259


Oct 1 17:30:13 hermes <ffffffff801602d9>{do_no_page+249} <ffffffff80160770>{__handle_mm_fault+400}

Oct 1 17:30:13 hermes <ffffffff80120176>{do_page_fault+1014} <ffffffff8010f179>{error_exit+0}

Oct 1 17:30:13 hermes

Oct 1 17:30:13 hermes

Oct 1 17:30:13 hermes Code: 0f 0b a3 71 2d 37 80 ff ff ff ff c2 9f 01 66 66 90 48 8b 13



Oct 1 17:30:13 hermes RIP <ffffffff80154ecf>{__rmqueue+191} RSP <ffff810017e11c98>



I wasn't able to reproduce those bugs, or fix them with a kernel up- or downgrade. Besids, the bugs mainly occured in these modules:


Oct 1 18:37:46 hermes Kernel BUG at "mm/vmscan.c":587

Oct 1 18:54:12 hermes Kernel BUG at "mm/rmap.c":493


Furthermore, some compile processes were terminated with the error "Speicherzugriffsfehler" (sorry, I'm from germany, translated: "memory access fault", or anything similar).


Finally, I tried to focus the problem, and ran my sys with only one module. One runs great (the one I use since Oct. :->), and the other produces these errors.


Then, I tried to verify the error with memtest, but until today, memtest has never detected an error!


Thanks for your time, I hope you can help me,





Sorry for my eventual bad English; I'm from Germany.

Link to comment
Share on other sites

  • Corsair Employees

Can you tell me the make and model of MB you have along with the CPU speed and it’s FSB as well? In addition, please tell me the bios settings you have set for both CPU and memory and any performance settings that you may have set? And have you ran http://www.memtest.org on them one at a time?

But this report could sugegst a problem with your software as well.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...