Jump to content
Corsair Community

XMS-Xpert fault

Recommended Posts

Hi there. I think I have a bad module. I have dual channel config that has been running fine for awhile now. I booted my machine up yesterday and noticed bios detected only 1 stick of 512 instead of two and hence only ran as a single channel. Upon taking the panel of my case I noticed that the LED display on one module wasnt working - The flags at the end were lit up but nothing in the text box.


I have tried taking out the memory and resitting it in different slots and have tried each stick on its own. When I put the faulty stick in on its own - the system fails to boot and i get a voice message that says "System failed memory test"

Numbers on the module are :



XMS3208 v1.2



look forward to your help!!


P.S. Please hurry! You have no idea how hard it is to play BF2 with only 512mb ram! Thanks

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...