Jump to content
Corsair Community

1 GB Flash Memory dies..


Recommended Posts



...this is already the second time this happens.


First time my memory stick was only running for 2 days. I went to the shop I bought it and got it replaced.


Now, the new stick worked properly for about 2 months and yesterday I put some files on it from my laptop, logged it off with the "safely remove hardware", put it into my desktop machine and nothing happened. No blue light, no USB device detected... Tried it again a second time and noticed a dialog showing up at the bottom right, saying something like "too much current at the USB Hub" and that the USB Port will gonna be deactivated. The message was in German, so I don't know exactly what it would be in english.

Anyway, I tried different things like resetting the USB Port, etc. but the Memory never responded. On the laptop there's no message but it just doesn't get recognized by the USB Port.


All systems I used it on were XP. USB drivers are also updated.


First I thought I got a bad stick, but now this is the second time in a row... could it be the computer? Seems also strange because it worked now on exactly those systems for about 2 months.


What about the data in that case? Completely lost or is it fixable?


Best Regards,


Link to comment
Share on other sites

  • Corsair Employees

I have no problem replacing the drive for you. But you might try it in another system to be sure, and you can try and gently wiggel it to make sure its getting a good connection.


Please follow the link in my signature “I think I have a bad part! Or *New* Tech Support Express” and we will be happy to replace them or it!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...