Jump to content
Corsair Community

2GB stick seems DOA


Recommended Posts

Purchased two nights ago.

Used for the first time this morning.

Plugged into my XP 'puter at work, recognized device, loaded a few files, clicked on the 'remove' icon, got an okey-dokie to remove, and removed stick.

Tried to plug back in to load a few more this afternoon.

No recognition, no winky lights, loaded disc, no change, unloaded disc, no change, turn 'puter off and back on numerous times.....still dead as the proverbial doornail. :(:

Same result when tried at home on my XP 'puter here.

Son-in-law works with this stuff for a living, he has the same luck after an hour of attempts. :roll:


'Bout ready to go back to Pencil & Post-It Notes.


Wazzzup wit' 'dis? :confused:



Link to comment
Share on other sites

Sony Vaio system from several years back running XP2002


I know Diesel Trucks......'puters are the relm of my local 'puter expert,...the 12 year old next door. :D:


Tried it in the two ports on the home pc, and the two ports on the work PC

(including the one that it worked plugged into this morning.)


It was a single stick, Package numbers read



Lot# 0543022-0


70584 00510 0


Hope this helps.

Link to comment
Share on other sites

OH, USB stick, not memory, LMAO!


Fill out the form here:



Also, I see you're an admin at http://www.dieseltruckresource.com. Saw your profile there (http://www.dieseltruckresource.com/dev/member.php?u=19529) and the hack I made to display PC components here may help you guys out there.


It's available for vB 3.0.x and 3.5.x for free in 2 simple to use vB hacks.









Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...