Jump to content
Corsair Community

TwinX2048 Problems


Recommended Posts

I've had this RAM in the system for about 5 months now and it works fantastic, today during a game of BF2 the system just hung, on reboot it fails the memory test every time.


I yanked one stick and it boots again, swapped the sticks over and it fails to boot. Tried to run memtest with the dodgy stick but the motherboard won't let it get past the "system failed memory test". The other stick is seemingly working ok.


Is there anything else I can check before submitting an RMA?


RAM Specs from the label:








bought from overclockers.co.uk

Link to comment
Share on other sites

Hi, something very similar happened to me. I got my memories yesterday. Everything was working alright, until I played BF2, too. The game crashed, so I had to restart the computer. Then, it just beeped. I tested both sticks on all the three slots and one of them is working fine, but the other one just makes my computer beep whenever I turn it on.

I tried to check compatibility problems, but even thogh Corsair web page says my motherboard (Abit NF7-S rev2.0) only takes up to 1.5GB RAM, the manual says it can take up to 2GB PC3200. I just don't know what happened and you can imagine how frustrated I am for not being able to use my memory the day after I got it.

What should I do? Do I have warranty?


My RAM specs:







Link to comment
Share on other sites

for now it seems overclockers are not living up to their reputation for slow or poor service, I got an email at work authorising the RMA to them, which will save a fortune on sending it back to the states.


I'll report back if there are any problems from here on in.


bearing in mind I can't memtest if it fails the POST is there anything left for me to test before i send it back?

Link to comment
Share on other sites

  • Corsair Employees

I am glad to hear overclockers will be assisting you with the RMA. Let us know if you need any further assistance.





As for your issue, I think it would be best if we replace that module set for you. Please see the link in my signature, "I think I have a bad part, what do I do?"

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...