Jump to content
Corsair Community

DEAD: Flash Voyager 1GB (RMA needed)


Recommended Posts

Bought new in February of 2005. Formatted FAT32. Use it with various Windows systems and Mac OS X machines.


One month ago I started to receive "disk full" errors when trying to copy files to it even though there was over 300MB free.


Backed everything up, formatted and restored backup. Problem solved.


Today I was copying two 10KB files to it from my Mac and the process would not complete - locked up the Finder (desktop) and I had to shut the machine down.


After reboot, OS claims the Flash Voyager is not initialized - this happens with Mac OS or Windows.


I have tried formatting with Mac OS Disk Utility as well as from Explorer in Windows on 5 different machines so far. No luck. It will not format. Windows produces an error and the Disk Utility in Mac OS will just spin its progress marker forever.


The Voyager is currently unusable and I'd like to proceed with an RMA.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...