Jump to content
Corsair Community

2GB SD recognised by pocket PC but not PC


Recommended Posts

O guru,


Have just purchased the Corsair 2GB SD flash media card 133x. I place it into my Pocket PC (HP iPAQ 4150) and it can be read, and recognised the full 2GB. I can copy files from the PC to the card while it is in the Pocket PC.


However when I place it into my PC (Toshiba Portege 3500 with Toshiba SD Card Controller Type A, XP Professional), it cannot be read. When I try to explore the drive, I am told the disk is not formatted and given the option to format it. When I choose 'yes' to do so, I am told the disc in drive E cannot be formatted. I tried using Control Panel's 'Computer Management', and going to the 'Disk Management' section, where E: appears as unreadable. I tried 'start menu', 'run' and typing 'format e:' to no avail.


The reason this is a problem is that I'm trying to install software onto the Pocket PC which requires that the SD card be placed into a readable drive on the PC and cannot install itself onto the SD card while it is in the Pocket PC.


Is there a hardware incompatibilty issue between this card and the Toshiba SD drive? I know the drive works with other, lower capacity SD cards I have tried.


Any suggestions for getting around this? Is there an external device which I could use as an SD reader to overcome this? I'm out of USBs but have a spare Compact Flash drive and, I think, a firewire port. Also bluetooth. Is there a device which will allow the compact flash drive to read SD cards? Any way I can turn one USB port into two with some sort of doubler/switcher?


Many thanks :)



Link to comment
Share on other sites

  • Corsair Employees


Some of these devices may not be able to see a 2.0 Gig device. But to make sure please test the flash card in a desktop or notebeeok system to be sure its not failing. Then please check with the maker of that device and make sure that

1. it will see fat 32 and

2. it will see a 2.0 gig device and

3. that you have the latest firmware for that device.

Link to comment
Share on other sites

Thanks Ram Guy, very prompt,


Managed to get around the problem by reading the 2 GB SD card from an external multi-card reader attatched to one of the USB drives and using another external CD drive.

I imagine the Toshiba SD Reader Type A is not able to read from cards bigger than a certain size. It certainly reads 1GB cards OK...

Hope this may be useful for other Toshiba users with a similar problem...


BTW the 'muscle man' part of your logo looks suspiciously like the sign that used to hang outside the Paradise Garage nightclub in NYC...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...