Jump to content
Corsair Community

1G Voyager - Stopped working. Saying disk is not formatted


Recommended Posts

I've a 3 months old 1GB Voyager that stopped working this weekend. Like many other people experiences on this forum, I'm getting the disk is not formatted error. I've tried unistalling the driver in device manager but it didn't help. I've tried it on several other XP machines, didn't help. I haven't tried to format it again as I want to see if there is a way to recover the data I've stored on the flash disk.


Is there a recall for the Voyager? This seems like a very common problem judging by the number of similar cases I read on this forum.


Last but not least, I live in HK and the drive was purchased through the retailer channel. How do I get this issue resolve?




Link to comment
Share on other sites

  • Corsair Employees


First thing we sell more than 50,000 of these a month, so you might see some people having the same problem, as this is a common symptom when there is a failure with this type of device, but when you consider the large volume we sell there are a relatively small number having problems.

Please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...