Jump to content
Corsair Community

The 4 Weeks USB-Stick


Recommended Posts



Today my second 2GB Corsair quit working. I called the thread "4 Weeks Stick", because both Sticks worked flawlessly for about a month. After that the first one told me on every PC i connected it, that a High Speed USB Device was plugged in a low speed Port (of course they all were USB 2.0) and the Stick simply was not accessible. I had it repalced and the new one worked until today. An hour ago it started to tell me that it was not formatted and I should format it. Every try to format or partition it ends with the error message "Format disk fail" or "Change Password fail". Is it broken again? I do not like to rely on a part that quits every Month, especially, when there are data on it which i just copied from a customers PC while reformatting his machine. Is there a chance to revive the Stick? If not, I would like to know your thoughts about these constant failures (I sure am not the only one with similar problems, as this forum shows).

Link to comment
Share on other sites

  • Corsair Employees

Please try the following to reinstall your flash drive and see if you can get it working correctly again:


Plug in the flash drive

Right click on My Computer

Choose Properties

Switch to the hardware tab

There should be a button like "Device Manager". Click on this.

Find your flash drive on this list. Right click on it and choose uninstall.

Unplug the flash drive, wait a few seconds then plug it back in.

You should now get a new hardware wizard dialog from which you can reinstall the drivers.

After reinstalling the drive test it again to see if it is working correctly and let us know. Thanks!

Link to comment
Share on other sites

Sorry, No.


Didn't change anything. Would have surprised me, because it showed the same behaviour an 4 different machines and I do not believe in "simultaneous driver disturbances". Funny thing is,when I looked in the device manager, the stick did not show up as corsair memeory stick, but as some different brand name (I suppose the OEM, but can't remember the name). After deinstalling it and reinstalling, the corsair stick showed up, but there was no asking for a driver, it simply showed the 1st partition drive letter in "My computer".


What next?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...