Jump to content
Corsair Community

Suddenly memory fails


Recommended Posts

Almost one year ago I bought a pair of VS512MB400 for my Apple G5 dual 1.8 GHz. they worked fine until about two weeks ago when strange things happened. I thought I had disk problems so I reformatted everything, zapped PRAM and installed system and apps from scratch. Still I had the same problems as before I decided to reinstall: applications crashed almost immediately after a while without any obvious reason. Never happened before.


I realized i had to do a memory test so i ran Techtool (4.0.5) and it failed the test (-2) many times. Then I also an memtest and it failed almost every subtest. I removed the pair of Corsair modules and everything worked fine for days. I remounted the pair and the problems returned immediately.


Is this good enough as a proof of bad modules or is there anything else I must do before aiming at the lifetime warranty.

Link to comment
Share on other sites

But they have worked fine for one year! No problems at all.


And everyone has adviced me to choose these sticks together with my system. Even one of Sweden's largest retailer of Apple products has tested them and recommend them. Many others do as well.


I have now tested my G5 with ONLY these sticks (Apple originals removed). First I didn't get the errors with memtest. I launched a few applications and most of them crashed on startup as they have not been doing for a week with the oroginal modules. So I did another memtest and WOW - all these errors are there again.


Here's about one percent of the output given by memtest:


Test sequence 1:

Stuck Address : testing 0FAILURE: possible bad address line at offset 0x09a3c25b.

Skipping to next test...

Random Value : FAILURE: 0x77fd32d1 != 0x77ff32d1 at offset 0x04bd229b.

FAILURE: 0xb3984a8a != 0xb39a4a8a at offset 0x04bd230b.

FAILURE: 0x7f7c9b2a != 0x7f7e9b2a at offset 0x04bd231b.

FAILURE: 0x7ec921d9 != 0x7ee921d9 at offset 0x04bd232b.

FAILURE: 0xefdf250d != 0xefff250d at offset 0x04bd2333.

FAILURE: 0xf54f2753 != 0xf56f2753 at offset 0x04bd233b.

FAILURE: 0x964da3bc != 0x966da3bc at offset 0x04bd23ab.

FAILURE: 0xd85ffd03 != 0xd87ffd03 at offset 0x04bd23eb.

FAILURE: 0xdf9f5012 != 0xdfbf5012 at offset 0x04bd23f3.

FAILURE: 0x64882ab0 != 0x648a2ab0 at offset 0x04bd225b.

FAILURE: 0xa4806643 != 0xa4a06643 at offset 0x04bd22bb.


- - -


How can I test them individually? My G5 requires modules set in pairs to boot at all.

Link to comment
Share on other sites

  • Corsair Employees

We can try replacing them if you like, but we would normally suggest our System Select for any OEM system for best compatibality.

Please follow the link in my signature “I think I have a bad part!” and we will be happy to replace them or it!

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...