Jump to content
Corsair Community

Corsair C2 announcement and twinx2048/c2


TheYak

Recommended Posts

Since modules were previously rated C2 for Intel and C2.5 for AMD, I'm assuming that this announcement only applies to RAM/Mobos purchased after the announcement date. If this isn't the case, I'd love to know since I dropped a decent chunk of change on twinx2048-3200c2's that I'm now looking at having to ditch for lower-latency sticks.
Link to comment
Share on other sites

ATTENTION EVERYONE THAT HAS HAS ASKED THIS SAME QUESTION:

 

New Latency for C2 Modules

Corsair is pleased to announce that effective immediately, all Corsair "C2" rated modules are guaranteed to run at a CAS Latency of 2 in all current production AMD motherboards!

 

This means ANY PCxxxxC2 modules on Athlon64 systems are guaranteed to run @ 2-3-3-6.

Link to comment
Share on other sites

This means ANY PCxxxxC2 modules on Athlon64 systems are guaranteed to run @ 2-3-3-6.

 

Very true. Only the Socket A AMD systems (Athlon XPs and some Semprons) need apply to the old CAS 2.5-3-3-6 recommendation on the unbuffered 3200C2 modules. (But then again, many Socket A systems use a 166MHz actual FSB speed, at which (PC2700/DDR333) the current revision of the 3200C2 modules will use CAS 2.5-3-3-7 timings if the user lets the BIOS detect the modules' SPD.)

Link to comment
Share on other sites

I checked the stickied threads in applicable forums and didn't see anything. Sorry for the oversight.

 

Alright, so is there a grand new setting that's been discovered to allow this, because my modules will not run at CAS 2, regardless of voltage, even when set to 8-3-3-2 with 1T. I've also (for the hell of it mostly) tried CAS 2 with a single module in any slot and running Dual and Single Channels. Everytime, CAS 2 causes no POST.

 

Linkage to tech question thread

 

Any suggestions or might they be not-up-to-spec modules?

Link to comment
Share on other sites

Sure thing,

 

A8N-SLI Deluxe BIOS 1.0.13

2048 TwinX3200C2 DDR400

AMD 64 3200+ Venice (rev. E) (2000Mhz, RAM 200DDR)

BFG 6800GTOC 256 PCI-E (at the time, now EVGA7800GTXKO)

Running 6.66 N4 drivers

Main HD: WD Raptor 74G SATA-150

Audigy2ZS Platinum

 

PSU: PC Power & Cooling 510-SLI

 

Memory Timings currently at 5,3,2,2.5/1T, as mentioned, relaxed timings don't allow CAS 2.

 

Thank you for the reply, even if it's all for naught if I misunderstood the guarantee.

Link to comment
Share on other sites

  • Corsair Employees
And what slots do you have them in? I would try the modules one at a time at Cas 2-2-2-5 1T and lets make sure they will run 1 up. And if you have them in slots 1-3 try them in slots 2-4 and see if that makes a difference.
Link to comment
Share on other sites

The modules won't hit 5-2-2-x, only 5-3-2-x, regardless of 1T/2T. In varying slots (A1/B1, A1/A2, A2/B2) they won't do CAS 2. I haven't tried a single on anything but A1 or B1, I'll give the others a shot. It's a bit of a pain since with no POST, I've got to reset CMOS everytime.
Link to comment
Share on other sites

Minor update: Tried 2.9v and got POST with 1 & 2 modules at 8-3-3-2 1T. However, XP dies on boot - BSOD. 1 module - I see the logo then get nvdisp.dll BSOD (nvidia display, since it's 100% stable at CAS 2.5 and have used both 6800GT and 7800GTX, assuming RAM issue). 2 modules - immediate OS BSOD with Paging error.

 

I'll try A2/B2 again with 2.9v incase I didn't seat correctly or something during initial swap-fest. (Why can't mobo manufacturers use a DIP switch or push-buttons for CMOS reset?)

Link to comment
Share on other sites

Well, tried again, w/ slots A2/B2. Voltages 2.7-2.9 with timings [CAS2, 8,3,3, 2T] yield Stop error C000001d @ c000021a.

 

Back in slots A1/B1, I get page fault in non-paged area. Kick 'em back to 5,3,2,c2.5 1T and passed 5 passes of memtest & 4 hours of prime95. They don't seem bad necessarily, just not up to specs. I'll try the return route though I'm a little it since I just got F.E.A.R. In any case, thank you. You guys rock once again.

Link to comment
Share on other sites

  • 3 weeks later...

I got the replacements a couple of days ago and have been running CAS 2 w/ no problems.

 

In fact, the latency on these things tests the same or lower than my previous 2x512 modules. I've got the Twinx2048 3200 C2's running 5,3,2,2 / 1T.

 

Thanks guys.

 

[Edit: May as well add, easing off timing to 6,3,2,C2.5/1T, easily grab a 220 (440DDR) OC. Now to tweak the timings for better bandwidth than low-latency running]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...