Jump to content
Corsair Community

Corsair Flash Voyager 512Mb Misbehaving


Psycholist

Recommended Posts

Much like a few of the previous posts, I'm unable to read data from my 512Mb Corsair Flash Voyager or to format it (Computer says the drive is write protected). Strangely enough when I open the format window the drive is listed as 248Mb in size too.

 

I installed the Corsair software and was unsuccessful in formatting the drive by this method too. Previously I had never used the software I got with the drive, nor has it ever been partitioned or password protected.

 

In common with one of the previous posts I had no problems with the drive for daily use in several computers (I used it daily to back up work to my home laptop), but then didn't use it for about a week and got this error. My previous USB key still works even after an accidental trip through the washing machine and well over a year's use and that didn't even claim to be waterproof (Its read and write speeds are best described as glacial however). The Corsair I have now hasn't got anything like that kind of abuse (It's carried in my pocket away from keys, mobile phones and anything else I can think of that might corrupt the data on it or physically damage it, same as the other key).

 

I get the same behaviour on both XP home and XP Professional OS computers. All USB connections are USB 2.0, other USB devices work perfectly in the same plugs. I tried uninstalling the USB device so the computer has to find and install itself and there was still no change in the device's behaviour.

 

Is there a software fix or should I request a RMA? Thanks.

Link to comment
Share on other sites

  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...