Jump to content
Corsair Community

RMA'd Ram killed my PC


Recommended Posts

Dear RamGuy,

 

I recently rma'd a stick of ram in exchange for a new one. I received the new ram a few days ago and installed it into my PC. Unfortunately, this turned into a total nightmare for me the past 4 days. :(: The first day I installed the ram I would randomly get blue screens saying something about my swap file and my PC would reboot. At first, it only happened rarely, but as the day wore on it got worse. So, I ran memtest86+ for a few hours and found no errors for all 3 sticks (1536mb) of ram. I ran memtest about 3 times as the problem persisted and all seemed well with the memory.

 

By the 2nd day, I could not even get into the bios at startup! Finally, after many hours of panic, I figured out I had to take the battery out of my motherboard and was able to reflash my mb with an old bios I had on a CD. :idea: I was able to run memtest86+ again and this time I tested each individual stick of ram seperately starting with the new one I received from Corsair. My PC would not even boot with the new ram installed. I tested my other sticks and they all work fine. I tried putting all 3 sticks back in and my bios says I have 1536mb installed, but when I run memtest86+ it gives me an error and says it can't run any tests. Now, everytime I install the ram I just received from Corsair I have to reflash my bios.

 

So, after loosing all my data in 4 days of the most serious computer meltdown I've ever had and suffering from a nervous breakdown until I got my PC working again, I've reinstalled Windows and came here to ask if this new ram is salvageable or do I need to send it back?

 

Sincerely, Matt P

Link to comment
Share on other sites

  • Corsair Employees

Matt I am sorry you had trouble, but I would suggest you call our Customer Service and ask if they can help you get all three modules replaced so they match.

Please either call our customer service at 888-222-4346 and dial "0" or follow the link in my signature "If you have submitted the RMA using the on line form and have not got a reply!"

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...