Jump to content
Corsair Community

iCUE v5.15.117 Release Notes


Recommended Posts

  • Administrators
Software Enhancements
  • Resolved an issue that prevented firmware updates from starting during the prompt for a USB cable to be connected
  • Resolved an issue that prevents the border around the Macro Recording area from blinking during a macro recording session
  • Voicemod SDK is updated to the latest version – however, “Instant Censor Beep” and “Mute for Me On/Off” are temporarily disabled until they are re-implemented in the SDK
  • iCUE will no longer fully quit while there is an active window prompt
  • Improved the design for progress bars and their associated buttons
  • Modules can no longer be deleted for devices that are still connected to the system
  • Resolved an issue that caused temperature units to be displayed in Fahrenheit instead of Celsius by default
  • iCUE will no longer crash while switching profiles during a pointer hover on an icon in Key Assignments
  • Profile names will no longer be allowed to exceed 255 characters
  • Info panels in Device Memory Mode will no longer have a text cut-off
  • Resolved some user interface issues that caused improper scaling in some of the device panels
  • Resolved an issue that causes iCUE to hang during the saving process of a hardware profile
  • The following devices have been added for Govee Support:
    1. H610A Light Strips
    2. H61E1 Light Strips
    3. H61D3 Light Strips
    4. H6065 Y Light Bars
    5. H6047 Light Bars

View full version

  • Sad 1
Link to comment
Share on other sites

Thanks, now all my profiles have the mouse configuration messed up.

Bring back the per profile "enhance pointer precision" and "Pointer Speed" options.

I'm tired of you changing options that broke the behaviour of components. Last time i buy a mouse from you! 🤬

Link to comment
Share on other sites

2 hours ago, TroyOnSails said:

Thanks, now all my profiles have the mouse configuration messed up.

Bring back the per profile "enhance pointer precision" and "Pointer Speed" options.

I'm tired of you changing options that broke the behaviour of components. Last time i buy a mouse from you! 🤬

Untitled.png.6c4185d6a9fac39ab9b1209f5349826e.png

  • Sad 1
Link to comment
Share on other sites

Not a reasonable solution. I had profiles with enhanced precision and others without it.

I use it in windows and strategy games but otherwise i don't like it.

The problem here is that Corsair is removing options from icue that change the behavior of existing profiles. The more profiles you have the more headache it becomes.

  • Like 1
Link to comment
Share on other sites

Anyone know if this fixed the issue with memory leds staying lit during sleep mode? Had to swap in different ram as only the Corsair ram would stay lit. 

Link to comment
Share on other sites

Will NOT stop crashing. Redownloaded, still crashing. Had it up for 10 seconds after finding a "Solutuion" elsewhere, all my profiles are gone for my 8 devices. Why is this so garbage? What is the fix.

Link to comment
Share on other sites

Posted (edited)

I upgraded fine, from a version 2 versions ago. Restarted the computer before I checked in iCUE. I did find that my hardware profiles for my keyboard had all of the same colors applied - even though in the old version I had "downloaded" some of my iCue profiles to the keyboard, each with their unique lighting effects. I removed them all from the keyboard but one - the default "hardware" color scheme I use for all of my iCUE devices.

Edited by ArgonV
Link to comment
Share on other sites

FYI if you find that iCUE is crashing or hanging a lot, do check your Controlled Folder Access settings. I had to allow a couple of Corsair's EXEs...

Link to comment
Share on other sites

20 hours ago, theonlybabyface said:

Anyone know if this fixed the issue with memory leds staying lit during sleep mode? Had to swap in different ram as only the Corsair ram would stay lit. 

Nope, still broke

Link to comment
Share on other sites

Does this fix the ram issue where it will lose connection with the ram requiring a reboot, or the wizard not detecting all the fans on the Commander Core XT device? Issues that version 4.x do not have.

  • Like 3
Link to comment
Share on other sites

Posted (edited)

Ever since you introduced the "performance manager" for DDR5 I haven't been able to use iCUE5 even though I do not touch the performance manager, Went back to the last version of iCUE4 and it is now fully stable, Tried this new version, Same issue, Instability, System hangs.

Edited by Dicehunter
Link to comment
Share on other sites

What a joke! If you unistall iCUE 5 and install iCUE 4 it doesn't detect the profiles anymore, profiles that where created under iCUE 4.

I can't understand how iCUE 5 became such a garbage. Online setup that makes impossible to revert to previous versions, incompatibility between iCUE 5 and iCUE 4 profiles, removed options that change the behavior of peripherals, changes in the interface that makes finding things more confusing (why you have to hide profile names?, really, why?).

Is chatGPT programming iCUE 5? It looks like it!

Link to comment
Share on other sites

Posted (edited)

To add my feedback,

On this and the previous version of iCue my ram - 32gb Dom Plats - has had a red error icon and RGB on them would not work.

A reboot did not resolve but force updating the firmware did however I would prefer not to have to update firmware and take write cycles off their NAND.

Once updated issue did not reappear until this latest version , this has also never happened on any previous versions.

Edited by andyvee
Link to comment
Share on other sites

On 5/29/2024 at 6:49 AM, TumK0 said:

The sensors of the motherboard are not fixed it's a pity(

I've been having the same issue for a few updates now, ever since they changed the CPU SDK. Many of the X570 (MSI X570 Carbon MAX Wifi) sensors do not appear in iCue at all since then, opening HWInfo64 shows them all functioning correctly (iCue is missing chipset temp, ambient temp probe, voltage/current readouts, etc.). Another bug that is frustrating is that often on startup iCue gets the motherboard sensors mixed up and I see the CPU temp numbers switched with one of the other motherboard sensors (I've had to change what sensors I'm using for fan control as this causes some of my fans to ramp up when they shouldn't), shutting down and reopening iCue usually fixes it the first time. 😞

  • Like 1
Link to comment
Share on other sites

19 hours ago, Devyphar said:

I've been having the same issue for a few updates now, ever since they changed the CPU SDK. Many of the X570 (MSI X570 Carbon MAX Wifi) sensors do not appear in iCue at all since then, opening HWInfo64 shows them all functioning correctly (iCue is missing chipset temp, ambient temp probe, voltage/current readouts, etc.). Another bug that is frustrating is that often on startup iCue gets the motherboard sensors mixed up and I see the CPU temp numbers switched with one of the other motherboard sensors (I've had to change what sensors I'm using for fan control as this causes some of my fans to ramp up when they shouldn't), shutting down and reopening iCue usually fixes it the first time. 😞

I agree with you, the sensors sometimes get confused on their own and there are also a lot of them and they show either 90C or 85C

  • Like 1
Link to comment
Share on other sites

Posted (edited)

Teams integration does not work on MacOs Sonoma headset mute button does not unmute teams conference call. 

OS:  MacOS Sonoma 14.4.1
Headset: Corsair Virtuoso Wireless
Teams Version:  Microsoft Teams version 24102.2214.2869.7475 client version is 50/24050307614.

Headset Firmware: 0.17.149
Dongle Firmware: 0.16.80

Edited by medive
Link to comment
Share on other sites

Hello how are you?
Well, let's go. I had the Corsair ICUE 5.10, I have 9 QX fans and an H60X Elite, using it calmly, when it started giving the error 'Unsupported operation attempt'...
 Well, I did all the solutions I found on the internet and nothing fixed it. this error. I remembered that on the same day I had updated the video card driver, from the 554 to the 555 and that was when this error started to appear. 
I completely uninstalled ICUE and NVidia with REVO, reinstalled it with the minimum of options for both without plugins or anything, and ICUE 5.11 was working for at least 2 days until the error came again. 
I managed to set the fans to 50% directly in the Ecossistem's memory so at least I don't burn my processor with the radiator coolers. But so, any solution? The only change from when I started using ICUE and QX fans was just the NVidia driver update. 
Now I have 9 practically unused fans... CORSAIR, is there a solution?
Link to comment
Share on other sites

Ive noticed since this update my mouse is extremely slow to move before logging into windows and only improves once iCUE fully loaded this was never an issue before with the M65 PRO RGB

Link to comment
Share on other sites

Posted (edited)

I don't know if the developers of the actual software ever actually read these comments but is there any chance you guys could work with ASRock to make the DDR5 "performance manager" compatible with their boards please ? So far it causes lock ups and systems hangs. If I completely uninstall iCUE5 and reinstall the last version of iCUE 4 everything works fine.

I'd like to buy some Corsair Link products but as the newer ones require iCUE5 it means I am unable to until you decide to fix it or not, If not I'll just start buying LianLi's products.

Edited by Dicehunter
Link to comment
Share on other sites

Did anyone notice? Last night, I updated version 5.15 of ICUE and found that the GPU usage rate increased (fluctuating) without doing anything during standby. I deeply regret updating version 5.15 now

My water-cooled LCD displays the load percentage of CPU and GPU, so I noticed this issue. The task manager also shows that the ICUE occupies GPU too high (approximately 10-20% fluctuation value)

My device:

CORSAIR-H170I ELITE LCD;

CPU-13900K;

GPU-GeForce RTX 3070 Ti SUPRIM X 8G;

I upgraded directly from a version before 5.12, and ICUE cannot roll back the version. Can anyone give me some advice? Thank you.

Link to comment
Share on other sites

5 hours ago, Comedy Maker said:

upgraded directly from a version before 5.12, and ICUE cannot roll back the version.

It's not the version, but far more likely some files were corrupted during installation.  The big change was the UI and moving the hardware device controls to a new format (Device Memory Mode).  Those changes have been live for 6 weeks and while there are a lot of issues still to stamp out, no one has been reporting high GPU usage.  

 

Export any valuable profiles you have (unless you already have them saved from 5.12), then follow the clean install directions.  This will erase all settings, murals, icons, and dashboard layouts.  However, most people should do this anyway on the first update to the new UI.  A lot of things changed and prior configurations seem to be difficult.  

Link to comment
Share on other sites

2 hours ago, c-attack said:

It's not the version, but far more likely some files were corrupted during installation.  The big change was the UI and moving the hardware device controls to a new format (Device Memory Mode).  Those changes have been live for 6 weeks and while there are a lot of issues still to stamp out, no one has been reporting high GPU usage.  

 

Export any valuable profiles you have (unless you already have them saved from 5.12), then follow the clean install directions.  This will erase all settings, murals, icons, and dashboard layouts.  However, most people should do this anyway on the first update to the new UI.  A lot of things changed and prior configurations seem to be difficult.  

Sir, thank you for your help.

To solve the problem, I created a new configuration file in ICUE. When I did not enable the "Murals" function, my GPU usage significantly decreased. To further identify the problem, I conducted a thorough investigation of three devices: "Commander CORE XT", "H170i ELITE LCD", and "K100RGB".

Firstly, it can be ruled out that the fault is not related to the "Device Memory Mode" function. The main problem lies in the lighting effect of the "8-LED Fan Series" (the device memory mode does not have the 8-LED Fan Series). Whenever I do not enable this function, the GPU occupancy rate will significantly decrease. If I enable the "8-LED Fan Series" GPU occupancy rate, it will significantly increase.

To make the above statement more convincing, I have attached some pictures for your reference. If developers can see it, I hope it will be helpful. It should be noted that GPU usage was very normal before the ICUE update version 5.15.117.

1.ICUE occupation too high.png

2.ICUE occupation too high.png

3.ICUE occupation too high.png

4.ICUE occupation too high.png

5.ICUE occupation too high.png

6.ICUE occupation too high.png

7.ICUE occupation too high.png

8.ICUE occupation too high.png

9.ICUE occupation too high.png

10.ICUE occupation too high.png

11.ICUE occupation too high.png

12.ICUE occupation too high.png

  • Thanks 1
Link to comment
Share on other sites

Ok, you left out that you were using a video lighting mural. That always will use measurable amounts of GPU resources. CUE also will use gpu resources in order to render the display effects in the app. Something like a KB with 100 LEDs will use a definite amount of gpu power to render compared to a device page with minimal objects. Whether these values are high or low is likely a longer discussion. 
 

Either way, this is substantially different than CUE is not open and using gpu resources or CUE is using high gpu resources regardless of which page is open. We probably need to get this moved to its own thread for more analysis. 

Link to comment
Share on other sites

On 5/28/2024 at 5:48 PM, John Hoang said:

Untitled.png.6c4185d6a9fac39ab9b1209f5349826e.png

Every time i change my mouse profile (DPI)  i have to go into windows and change the pointer speed, and you think that's a solution?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
×
×
  • Create New...