Jump to content
Corsair Community

k57 keyboard multiple keys suddenly stopped working


Recommended Posts

Ive been using a k57 keyboard and harpoon mouse combo for a couple of months now. this morning while I was actively using the keyboard, multiple keys suddenly stopped working.

t - y - [ - ] - 4 - 5 - 6 - backspace

the 456 keys are only not working on the numeric pad.

Its bizarre that they all stopped working at the same time. Ive tried resetting the keyboard (light pattern turned to rainbow spiral - but didnt do much else), have used it on another PC and had the same result. have tried wireless and usb cable and still have same result. really makes no sense at all.

the reset procedure I was trying was to turn the kb off, start it with escape pressed and release after 5 seconds. only the lights went spiralled but it didnt flash like the instructions said it was supposed to. is there any other method I can try to reset it?

Link to comment
Share on other sites

Just raising a hand here too - my brother just got this same issue with his K57 too - spacebar, B, and N just stopped working - probably some more keys we haven't found yet.

Tried the reset procedure you mentioned and it's completely ignoring that too 😞 

Link to comment
Share on other sites

  • 2 weeks later...

I ended up watching a few youtube videos on issues with keyboard circuits and how to repair it, and took mine apart thinking I had nothing to lose. there wasnt anything noticeably wrong with any of the circuitry (I'm not an expert, just did basic conductivity tests with a small meter) so I just disconnected the 2 ribbon cables, gave them a bit of a clean and reseated them. All the dead keys came back after that so it must have just been one of the pins in the ribbon cable being slightly off. Im a light typer so I dont know how it could have become dislodged in the first place but anyway its working again and I am typing this using the keyboard. There was only 1 hidden screw under the sticker in the middle of the back of the keyboard, it ended up a really simple fix.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...