Jump to content
Corsair Community

There is an exclamation mark on the LCD screen and the computer does not see Corsair Commander Core


Recommended Posts

Hello, Corsair Elite LCD has 360 mm liquid cooling. I changed the computer case. While there was no problem before, I encountered a problem afterwards. The icue application does not see the Commander Core, which is the controller of liquid cooling, and therefore the LCD screen does not work. However, liquid cooling itself works and cools the processor. I cannot see Commander Core in the icue application. There is always an exclamation mark on the LCD screen and there is a constant sound. Thanks in advance for your help.

Link to comment
Share on other sites

Shutdown the pc and flip the PSU off. Disconnect then reconnect the wide power cable from Commander Core to lcd top. Also remount the lcd top on its communication port. Flip the PSU back on and start normally. This is typically a communication error between the devices. 

Link to comment
Share on other sites

10 hours ago, Agademo said:

I can't see Commander Core in the icue app.

You should not see the Commander Core in CUE.  You should see the pump LCD.  In that tab will be both the pump/lcd controls as well as the fan speed/RGB controls normally associated with the Commander Core.


If neither device shows in CUE, you may need to check the USB connections.  That is how the device and software communicate.  Specific motherboard series chipsets can be finicky.  It obviously worked before, but this is something that can no longer work if the plug gets jiggled the wrong way.


If it's still not working, start a Support Ticket with Corsair form the link below or the main website.  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...