Jump to content
Corsair Community

iCUE 5.8.130 dashboard bugs - one apparently caused by storage widget enablement.

Citizen Crazed

Recommended Posts

So, just noticed a couple of issues that might be related to the crashing on startup others have reported after updating to iCUE 5.8 (running on Win11 23H2, build 22631.2506)

The simple one first:

"Hide Graph" no longer persistent

Clicking 'Hide Graph' on any of the dash widgets is now non-persistent. It used to be permanent - hiding the graphs in a widget kept them hidden through app/OS restart. They now reappear after an iCUE restart. Not ideal, but there are worse things afoot:


Storage Widget enablement makes Dashboard widgets disappear

Context first, my Dashboard *should* look something like this:


However, when I enabled the storage widget earlier,  while drive temperatures subsequently displayed as expected, after the next iCUE or Windows restart, the dash loaded incompletely.  For example:


Missing from that screengrab are the widgets for the CPU, motherboard and graphics card - as well as the drive widgets themselves. Also note that the DRAM widget is failing to display the memory timings.

Checking the Dashboard customisation page, the "non-Corsair"  items are now completely absent, so I can't even manually add them back:


This is despite the fact that the motherboard is stlll visible within the iCUE homepage:


As you can probably tell from the screenshot above, I've tried a complete uninstall/reinstall of iCUE to fix this issue - but it remains even after a clean reinstall.

After a bit of guesswork, I have positively tied this bug to the enablement of the storage widget.

When I disabled the storage widget and rebooted the PC, iCUE intially crashed on startup - and tried to send a diagnostic log. It did this again the second time I restarted the OS. However when I subsequently restarted iCUE from the Start Menu, the app loaded and the dashboard once again displayed fully. After this, subsequent OS restarts do not cause iCUE to crash.

This behaviour is completely reproducible: If I enable the drive widget, close iCUE and then restart it, the dashboard is broken/incomplete. If I then disable the storage widget, close iCUE and restart it, the full dash (bar the disks obviously) displays again without problem.

So, for some reason, on this system at least, having the storage widget active at app start corrupts the dashboard somehow. Anyone else able to reproduce this?

Link to comment
Share on other sites

Very odd, I do have the storage widget enabled with my system and do not see this issue. Though, when I click to enable or disable it - it takes iCUE a hot minute to do so and it goes unresponsive for a few seconds.

I had other issues after upgrading though, many of my sensors were duplicated. Got that fixed by deleting the config files for them and letting iCUE reinit them all.

Link to comment
Share on other sites

Thanks @ArgonV, it's a strange one to be sure. I've never seen anything like it before either, and can't positively swear that it was introduced in the latest iCUE build as I don't normally have the drive widget active so it *could* have arrived some time ago without me noticing. And, one of the downsides of the new modular file download is that it isn't possible to sequentially install older builds to identify when the bug first appeared. So, in Corsair's hands a bit more so it seems.

Link to comment
Share on other sites

Mine keeps crashing and I can't go to disable anything in time. Is there a way to disable it by modifying the install files?

Link to comment
Share on other sites

I have also noticed an issue when I enable the storage widget that could be linked, with it enabled the windows anti-malware service in taskbar constantly bounces between 1-6% cpu usage (normally sits at 0% with the odd lift to 0.5% here and there) and raises cpu idle temps by about 10 degrees C.  I’ve also ran cinebench with and without this enabled and lose around 1000 points when it’s enabled.

Link to comment
Share on other sites

Mine keeps crashing sometimes it will run for a few hours, sometimes it repeatedly crashes. it Generates a debug report i can send to corsair. I have Preformed a clean uninstall deleting all registry entries but nothing stops it. I wish corsair would get off their ass and test their software before releasing it.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...