Jump to content
Corsair Community

icue h100i/h115i elite capellix (firmware update broke multiple aio)


Recommended Posts

I have several corsair products and I have been a fan of their hardware for a long time.

  That being said I recently tried to upgrade my firmware for my two coolers only to have the same problem occur on both devices. after the update the cooler cannot detect pump speed and reports "Pump failure".

  I swapped out my commander core from my h115 to my h110 (same part#75-004278) and got the same error.  I then hooked up my h115 and its controller and everything worked great.  when I opened ICUE it prompted me to update the pump firmware again but for the h115i  so I did.  Shortly after the update I again got pump failure alert.  So I unplugged the cooler and swapped in  my OEM air cooler to boot the machine and tried to update the firmware for the commander core. After it had  updated I hooked the AIO back to the Processor and turned it back on.  It immediately gave temperature warning and my motherboard shut the pc down.  When I restarted the computer and booted into windows the AIO wouldn't show up in ICUE software and my temps were climbing fast.  Apparently the firmware update bricked my h115i's commander core (it doesn't work at all). so now I am running on the h110i and its original commander core both on newest firmware. it constantly gives pump failure warning in ICUE it can't see the pump speed but it is pumping and all my fans blink red as well as the pump head.  My system is running but it keeps giving pump failure warning.  I tried to find a copy of the old firmware but it doesn't seam to exist. As you can see in the attached file coolant temps are amazing so it is pumping.

I am kind of upset as I now have several failed corsair products. and it seems to only be the newer products as all my older stuff still runs great.

2x bad hx850 power supplies

1x bad 140mm series 8 fan

2x bad AIO coolers

3x bad 120mm series 8 fan

1x stick vengeance pro RGB that wont stay synced

Sorry for the "venting" its just becoming a lot of money for my VR arcade business. URVR

 

h110 error.JPG

Link to comment
Share on other sites

  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...