Jump to content
Corsair Community

Unresponsive Corsair M55 RGB PRO Gaming Mouse after Firmware Update

Recommended Posts

Hello fellow Corsair users,

I hope you're all doing well. I wanted to share an issue I'm currently facing with my Corsair M55 RGB PRO Gaming Mouse. I recently attempted to update the firmware using the Corsair iCUE software, but unfortunately, the mouse has become unresponsive since then. I've tried troubleshooting on my own, including a reset by holding down the left and right mouse buttons, but haven't had any success.

To provide more context, after disconnecting the mouse during the firmware update, it ceased to be recognized by the software. Upon reconnecting it, I discovered that the mouse no longer functions at all. Even the LED lights no longer illuminate when the mouse is plugged in. I also tried connecting it to another computer, where it was identified as a "CRP DISABLD" storage device and failed to work properly.

If anyone within the community has encountered a similar issue or has any suggestions on how to rectify this situation, your assistance would be greatly appreciated. Thank you for your time and support.

Best regards,
Ahnaf Patwary

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...