Jump to content
Corsair Community

H150i ELITE LCD XT Red Triangle/Exclamation Point

Recommended Posts

Originally, I had the H150i ELITE LCD (non-XT version) installed in my system and it was working perfectly.
After replacing my motherboard with something a little newer (Asus Crosshair VIII Hero to a Crosshair Dark Hero w/ newest BIOS as of June 2023), the LCD screen on the pump would only show a red triangle/exclamation point. In iCUE, just "Commander CORE" would appear. I could still control the fan speeds/RGB and the "Coolant Temp" sensor was also available. The pump itself appeared to be functioning and moving coolant, although I could no longer view the RPMs via iCUE. When the system would boot, the LCD display would show the typical Corsair splash screen and then the generic circling "Temp" screen for split second before returning to the red exclamation point/triangle.
I was going to reformat the system and reinstall Windows anyways (due to replacing the motherboard), so I didn't give this issue much thought and didn't troubleshoot anything at the time.
After completely reformatting and reinstalling Windows...

Same issue. Red triangle/exclamation point.

Besides installing the newest chipset and GPU drivers from AMD's website, no other software had been installed yet so absolutely nothing else would have interfered with iCUE (like Armory Crate). I double-checked the wiring and made sure everything was snug, reseated the LCD screen on the pump, switched off the PSU for a minute, plugged the USB ends into their own headers on the motherboard instead of using the Y-splitter, reinstalled iCUE v5.2.128 (includes deleting registry keys and the folders in %appdata%), force updated the firmware (Commander CORE v2.0.19), and also tried using a powered internal USB header splitter from NZXT. When installing iCUE, "LCD Screen" is on the list of detected devices and appears in Software Updates as "LCD Screen Pump Display" along with its appropriate icon.

Same issue. Red triangle/exclamation point.

Thinking I had somehow bumped/damaged the AIO when replacing the motherboard earlier and that might be the cause of the issue, I decided to buy the newer H150i ELITE LCD XT. I hadn't got very far in setting up my system previously, so I reformatted and reinstalled Windows again after installing the new AIO.

Same issue. Red triangle/exclamation point.

Although this was a brand new AIO, I did all the same troubleshooting steps as before anyways and also tried installing an older version of iCUE (v4.33.138) and even downgrading the BIOS on the motherboard, but still got the same result.
So now I was thinking, maybe something was wrong with the new motherboard?
I put the previous motherboard (Asus Crosshair VIII Hero) back in and reinstalled Windows...

Exact. Same. Issue.
Red triangle/exclamation point.


I'm at a loss and have spent soo much time and money on this.

Any other ideas? Is there something I'm maybe missing?

Otherwise, with everything I've done, I can only assume there's something wrong on Corsair's software/firmware end of things that desperately needs fixing ASAP (especially considering the cost for such devices)...


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...