Jump to content
Corsair Community

iCUE H150i Elite Capellix XT - Pump no light

Recommended Posts

Since I started up my newly built computer there is no light from the pump. Everything else seems to work, like fans and dashboard. The pump itself is running and cooling is working but no light.

Any clues where to start troubleshooting?

I have already tried to reconnect the connection from pump to the commander core. The pump is also connected to CPU_FAN on the MB.

See specs below.







Operativsystemets namn    Microsoft Windows 11 Pro
Version    10.0.22000 version 22000
Operativsystemets tillverkare    Microsoft Corporation
Datortillverkare    ASUS
Datormodell    System Product Name
Datortyp    x64-based PC
System-SKU    SKU
Processor    13th Gen Intel(R) Core(TM) i9-13900KF, 3000 Mhz, 24 kärnor, 32 logiska processorer
BIOS-version och -datum    American Megatrends Inc. 0813, 2023-01-10
SMBIOS-version    3.5
Version av inbäddad styrenhet    255.255
BIOS-läge    UEFI
Baskortstillverkare    ASUSTeK COMPUTER INC.
Baskortsprodukt    ROG MAXIMUS Z790 HERO

Link to comment
Share on other sites

Set any pattern in Hardware Lighting for the pump, then manually quit CUE from the system tray or Task Manager.  Does it light up then?  If not, it may have blown its LED controller in the pump.  


If this is a new unit, exchange options with the purchase vendor is probably the fastest solution.  If you'd had it longer, start a Support Ticket with Corsair from the main website or link at the bottom to do the same through them.  

Link to comment
Share on other sites

Thanks for your reply. I tried your proposal but it did not work. I think it might be a blown LED controller.

The unit is brand new so I should contact the vendor for a solution. If I had lived in the USA I would have purchased  a "Elite Capellix RGB Module Replacement" and tried that solution top save time. Cannot find a replacement in Europe.




Link to comment
Share on other sites

Yeah, unfortunately it does seem like a blown RGB controller. We have not seen too many of those and I wasn’t aware they carried a direct replacement for it. That does present another option. If you contact Corsair Support, they can send you that piece only as part of the warranty coverage. Not sure if that is better for you vs exchange with the purchase vendor. 

Link to comment
Share on other sites

  • 2 weeks later...

Hello, I have a similar problem with me, the pump pumps, but it does not light up. Mine is also not even recognized by iCue. The RGB fans plugged into the Commander Core are recognized.
Please help

iCUE 17.06.2023 21_11_08.png

Link to comment
Share on other sites

Your issue is different and more common.  The software is not detecting the pump along it's USB path.  You can't control it if CUE can't see it.  


Is this an LCD top version?  Some motherboards do not like the Commander Core and LCD top to share a USB path on the splitter.  Either way, the first troubleshooting step is going to be to shutdown the PC, then flip the PSU switch off for 30 seconds.  During that time, disconnect and reconnect the wide power/data cable on the side of the Commander Core.  Flip the PSU back on and start normally.  This should cause the Commander Core to do a deep check of all its connections on the next boot.  

Link to comment
Share on other sites

Thank you for your reply. Yes, I also have the LCD upgrade kit, as soon as I use your tip with this nothing happens. Now I have mounted the normal RGB cover and tried your tip now it is recognized but with an error. It flashes red and the fans are running at full speed

Screenshot 2023-06-18 154520.png

Link to comment
Share on other sites

The red triangle is a real pain and can mean several different things -- some fixable, some not.  Given that is was not there until you started working changing the top, this is likely the fixable kind and not the permanent type.  You don't have to remove the LCD top, but it can be very particular about how the USB is connected.  You likely cannot put the Commander Core or LCD top on either of your Commander XT passthrough ports.  You do have 3 Commander Core/XT and a LCD top and that is where we have seen issues before.  Or is that extra Commander XT and error?  Is was not in the first picture.

Link to comment
Share on other sites

I have now only connected a Core Xt once again, so that only the AIO components are on the core. but that didn't help either

Edited by Luser22
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...