Jump to content
Corsair Community

Corsair Virtuso Not Showing Up In ICUE 5.2.128

Recommended Posts

  • 2 weeks later...

I fixed it by setting it to not wireless and plug the charging cable in. Then it detected the headset and said it needed to restart the PC. After restarting I wait for ICUE to open and make sure its detected again, take the charging cable out and put it to wireless. It now detects the headset

Link to comment
Share on other sites

Tried all that and it is besides the point. If they're going to release software with additional steps, they need to express that. More to the point, if they're going to release software that is broken, they need to prioritize that for resolution. And I have plugged mine in, deinstalled, reinstalled three times across two separate versions. Unusable. It is time for them to get this corrected for those affected.

Edited by xox
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...