Jump to content
Corsair Community

iCue not recognizing GPU anymore

Go to solution Solved by crashnburnxp,

Recommended Posts

This happened sometime last year too when all of a sudden the icue software no longer wants to detect the Asus GPU without admin rights. I noticed I was having this issue again, closed out of iCue software and ran it as administrator and now the GPU is detected fine.

Performed multiple reboots as well to no avail. Also tried having the software load as admin on system boot and that did not work either.

Please fix soon.

Link to comment
Share on other sites

  • 2 weeks later...

iCue is now not detectring my Corsair monitor.

Link to comment
Share on other sites

  • 1 month later...

This is still an issue. I have tried uninstalling/reinstalling icue, tried running it as administrator and have also tried reinstalling the asus plugin to get it to detect my GPU and motherboard. Nothing.

This needs to be addressed

Link to comment
Share on other sites

  • 3 weeks later...
  • Solution

So i found out that i have to have the armory crate software from Asus installed rather than an older version of Asus Aura Sync. Once I installed the crate crap, icue instantly detected my GPU and motherboard. Even though it was fine a few months ago. So my theory is that Asus worked out a deal with Corsair that they not support Asus products unless the armory crate software is installed and meets a certain version.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...