Jump to content
Corsair Community

Odd failure...


Gerbil

Recommended Posts

I think my Corsair 2x256MB TWINX2700LLPT is incompatible with itself. I'm trying to run the set on an Asus A7N8X Deluxe 2.0 with an Athlon XP 2500+. It won't pass Prime95 (fails in under 1 hour, but usually within 15 minutes), and it usually reports an error in memtest86+ in Test #3 within the first 30 seconds.

 

I have it running at 2-2-2-11 and 2.6V, but I'm also getting the errors at higher latencies and 2.7V.

 

I tried one stick in the first slot and it PASSED. So, I tried the other stick, and it also passed. Then I tried each stick in slot three and each passed separately again.

 

However, as soon as I install the sticks together, memtest86+ reports an error in test #3.

 

I ran the same CPU and motherboard together with a set of Corsair 2x256MB TWINX3200LLPT for over a year with no trouble, and then for another year with a set of 2x512MB PC3200 (another brand), also without problems.

 

Full system specifications:

 

Asus A7N8X Deluxe 2.0

Athlon XP 2500+

Corsair 512mb TWINX2700LLPT @ 2-2-2-11

MSI GeForce 4 Ti 4200 64mb

Sound Blaster Live! 5.1

Seagate 120gb 7200.7 8mb cache 7200rpm hd

Black Lite On 48x24x48x16 Combo Drive

Enermax EG465P-VE 431W daul fan PSU

Aluminum Chieftec case with two 80mm exhaust fans

 

Here's the deal. I rebuild the computer and installed an Athlon XP 2000+ and the 2x256MB TWINX2700LLPT for about 6 months with no problems, but the 2000+ only runs at a 266MHz FSB. When I reinstalled the Athlon XP 2500+ that I'd had in the motherboard for the past two years (but the first time with the TWINX2700LLPT), the problems began.

 

So, why is it able to pass memtest86+ with either stick of RAM, but not both together? I've tried slots 1 + 2, slots 2 + 3, and I swapped the sticks in the slots in each configuration. No luck.

 

I'm going to try taking the memory speed down to 266MHz to see what that does, but I shouldn't have to do that.

Link to comment
Share on other sites

Sounds like the memory controller is having problems.

 

So you think the board is bad? After working fine for two years with other memory at the same speeds and same CPU?

 

I ran memtest86+ for over 12 hours at 2-2-2-11 with a 5:4 FSB/Memory ratio (CPU still at 166x11, RAM at 133x11). It found 0 errors. The last time I had a bad memory controller, the system would fail no matter what speed I ran the FSB/memory.

 

Edit:

 

I tried the Corsair TWINX in an MSI K7N2G-L and an Asus A7N8X-X (single channel only) with the same 2500+. It passed in both boards after 1 hour of testing (that should be enough since the A7N8X Deluxe consistently fails in less than 1 minute). I now have the 2500+ and some generic 2x512MB PC2100 RAM back in the A7N8X Deluxe running memtest86+ at a ratio of 5:4 again. It's passing.

 

I'd like to try two stick of PC2700/PC3200, but my only other set is my Corsair 2x1GB TWINX2048-3200C2PT, and it's 100% stable in my A8N-E. I'd rather not touch it.

 

I don't see any reason for the A7N8X Deluxe to be at fault. It ran perfectly for over 18 months with that CPU and two different sets of RAM at 333MHz at 2-2-2-11 and the aggressive CPU setting the entire time. I only clocked it down to 266MHz for now because I had a slower CPU in it...this is the first time it's used this TWINX though.

 

However, the TWINX is obviously not at fault either since it works fine in two other boards.

 

Could it simply be one of those odd incompatibility issues between a motherboard and a particular set of functional RAM? I'm tempted to order a set of Corsair 2x512MB Value Select PC3200 to find out. I have no reason to believe either part is defective.

 

Oh, and I noticed that the error is consistent. It always occurs in test#3 at 158.9MB, and it's always the same mistake: 40404041 instead of 40404040. It's not a stream of errors, either (just four). I thought that memory controller errors usually generate hundreds or thousands of errors.

 

It's been running like this for over a week and I simply hadn't taken the time to test it. We played HL2 for over an hour on it, and it hasn't crashed at all over the course of the week, so it's at least somewhat stable.

Link to comment
Share on other sites

I think we're both correct. I checked for BIOS updates since the BIOS was the latest one when I bought the motherboard two years ago :laughing:

 

One of the BIOS updates between then and now mentioned a fix for compatibility with Hynix chips. I flashed to the latest BIOS, and voila. It's been running memtest86+ for 53 minutes (2 passes and 81% of the third) with 0 errors.

 

Therefore, the RAM is fine, the CPU is fine, and the motherboard was not faulty. I'm going to let it run memtest86 overnight to be sure, but I think the BIOS update resolved the issue. If it does pass, then yes, the memory controller had struggled due to a buggy BIOS.

Link to comment
Share on other sites

You're welcome. I posted when I only had preliminary results (half a pass of memtest86+). It's been running overnight and has now done over 9 hours and 28 complete passes with 0 errors.

 

So, the problem is solved for sure.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...