Jump to content
Corsair Community

"Corsair 1G USB" Memory Loss Problem


Nat_Gross

Recommended Posts

Less than a month ago I bought a "Corsair 1GB USB Memory Module".

It have preformed without error until today. As of late night I downloaded some files off of the unit a then turned of the computer, this morning when I turned on the computer the "Corsair 1GB" would not work.

I have since tried it on 3 PC, one with WinXP Pro and two with Win98. The module use to work on all of them, but today it tells me that the module is unformatted. I have tried ejecting and reinserting the unit about 40 time on all 3 PC, once it displayed the contents, but when I tried to copy them to my HD it said the contents where no longer available and I needed to format the module.

I desperate, I have several hundred hours of irreplaceable research data stored on the module.

What should I do?

 

Nathaniel Gross

Link to comment
Share on other sites

I used some data recovery tools and was able to retrieve about 90% of my data. Though this is unacceptable it is better than a total loss. I'll add that it took almost 8 hours to recover the data.

 

After I retrieved the data I formatted the module and now it seems to work fine, however since it crashed once the modules integrity is in question. So I am going to exchange it for a replacement.

 

Nathaniel Gross

Link to comment
Share on other sites

  • Corsair Employees
I have no problem replacing the drive for you, but what you have posted might suggest a voltage problem with your system. You might check the power source for your USB Hub's on your MB and set it to the + 5 Volt rail.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...