Jump to content
Corsair Community

Commander Core XT Firmware Update Failed


Recommended Posts

Good morning.
I have purchased a commander core XT currently in version 1.0.29. When ICUE starts, it tells me that there is a Firmware update to version 1.4.62. When trying to perform said update, it gives an update error message and the window closes. I have tried to change the usb connector of the Commander Core XT to the different ports of the board as well as to install both version 4 and 5 of ICUE. Also from a clean installation of Windows 10, the result always being the same. Could you help me?

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 months later...

I had the same problem.  I have a gigabyte motherboard with rgb fusion and app center software.  I went to gigabyte's website,  downloaded the new versions to my desktop.  I then uninstalled both from my computer.  Then I tried to update XT.  It updated without a hitch.  I was going to reinstall the hub that came with the case.  Now I don't have to.   Whatever software is causing icue to fail to update in your system, has to be removed temporarily. Good Luck

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...