Jump to content
Corsair Community

iCUE does not open, including new version 5


JJV

Recommended Posts

I have been having lots of problems with my ORIGIN PC with exclusive Corsair products. iCUe routinely has stopped working and I would have to recover my PC to an older state so it could work again. Windows updates or installing any program would kill it i felt like. Now it's gone past the point of return with ICUE 4 that it wasn't opening or working despite recovering an older state. This is  brand new computer with hardly any software on it other than a games and windows 11. I went ahead and installed ICUe 5 and low and behold it does not open, my hardware its not lighting. I am so frustrated with this software can someone help me??? i have a k100, nightsword rgb, all the fans and the headphones. none of them i can control!!

Edited by JJV
Link to comment
Share on other sites

Having the same issue since the 4.33 update as you. I found going back to 3.38.88 resolves the problem. 

It seems corsair doesn't really care for performance or if you can even use the product the intended way as long as you buy it/give them money they're happy.

I tried to place the 3.38 file here for you since corsair removed it from the site but it was blocked. Best of luck. 

Link to comment
Share on other sites

20 hours ago, JJV said:

ok so 3.38 kinda works but doesnt recognize my k100. also it no longer works ughhhh

I started having this issue this morning. I have a commander core xt. Not recognized, no control, all fans at max rpm.

Downloading the new version recognizes them and sets them to silent, but I cannot open the program, repairing has no affect, and it does not appear in task manager once so ever like 4.33 did.

I have tried repairing, uninstall-install, run as admin, set to only run as admin, set to open on power on, set not to open on power on. The new version is worse than the old.

 

Sorry I couldn't help.

Link to comment
Share on other sites

  • 3 months later...

I can't get any version of iCUE above 4.33.138 to work.
Supposedly, v5 and up are supposed to be slimmed down, but they must have cut something out because even on some of the latest hardware, it does not work. I recommend installing the version I have listed and just not updating it anymore. It's not worth the hassle

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...