Jump to content
Corsair Community

iCue 4 (latest version) freezing when trying to connect K100 Air? Any advice?


Recommended Posts

I recently cloned an SSD for a new build and iCue 4 no longer recognizes my K100 Air. It recognizes my motherboard, but not the keyboard. It also does not allow me to run an update check on the keyboard (I'm assuming because it's not being recognized). The behavior of the program is also strange, iCue opens at startup, but the moment I try to reconnect my K100 Air via USB or through the dongle, the program freezes and I have to force quit. I also can't re-launch the program until a PC restart. Program was running fine before on my previous build. 

Tried to uninstall / reinstall multiple times. Tried to clear registry and delete relevant files, nothing. Any advice would be appreciated. Running latest version of iCUE. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...