Jump to content
Corsair Community

Ironclaw RGB Wireless


Recommended Posts

My Ironclaw RGB Wireless will only connect and be usable while it is connected with the provided cable.

I have been using this mouse for a little under a year with 0 issues. Works great. But, as many of these posts seem to start out, I unfortunately updated iCue. After the update, I can no longer use slipstream. The dongle itself wont even show up through iCue as it did in the past. I've tried everything that people have pointed out in other threads, and on corsairs support page. 

In order of all the steps I took; tried all usb slots on my pc for the slipstream dongle, reset the mouse (holding left and right click while turned off and turning it back on), tried to update iCue again, force updated iCue, reinstalled iCue, change power settings to not disable my usb slots, banged my head on the wall a few times, and restarted my pc after completing most of these steps. I'm becoming increasingly more upset with Corsiar, but more particularly iCue. I fear hitting the firmware update button every single time it appears, praying to every deity imaginable that I will not be spending the next few hours trying to google a new issue that I've never had before. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...