Jump to content
Corsair Community

Scimitar RBG Elite mouse causing ICUE to not open and/or crash

Recommended Posts

Good evening,

My Scimitar RBG Elite mouse does not work with the ICUE software. Whenever I open ICUE with my Corsair mouse plugged in it does not open, however, if I open the software with a normal mouse (and my corsair mouse unplugged) it opens immediately. If I then proceed to plug my Corsair mouse in and click on the ICUE software it crashes.

I have done a clean reinstallation (using the guide on the Corsair website) and i do not have any of the following software installed (which can cause the software to crash): Aura Sync, Armoury Crate, Mystic Light, Dragon Center.

Any assistance available would be highly appreciated.




Graphics card

- NVIDIA GeForce RTX 3060 Ti

- 8 GB GDDR6


- 16 GB DDR4 (3200 MHz)

- 64 GB maximum installable RAM


- Intel® Core™ i7-12700

- 12-core

- 2.1 GHz / 4.9 GHz

- 25 MB cache




Gigabyte B660M DS3H AX

corsair specs.jpg

Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)

hi mate sorry for the late response. I got in touch with Corsair's helpline and they took about 3-4 weeks in order to get back to my query. They were responsive once they assigned someone to my case (i would say i received a response every 2-3 days). But to answer your question, yes i have now resolved the issue.

In the end the issue was an app that I downloaded that I typically use for work called Citrix which was stopping my ICUE from working. This app has nothing to do with ICUE but every time i used it I would get an error message on Citrix. If you're experiencing any error messages with any software you've downloaded maybe try uninstall and reinstall them and see if the error messages stop and ICUE stops crashing? Or if that doesn't work maybe uninstall any apps that you think could be conflicting with ICUE. Failing that, over a few exchanges there were several things that Corsair suggested I do to resolve the problem. I've listed them in order, starting with their first suggestion to the last. Prior to speaking with Corsair i also did a "clean reinstall" of the ICUE software per the Corsair guide i found online. Hopefully this helps and saves you a bit of time conversing with Corsair:


First response:

Please ensure that your USB drivers are up-to-date.
If needed I'd also recommend uninstalling and reinstalling the mouse drivers.
If you're able to, please try the mouse with iCUE on another computer to see if the issue still occurs.
Could you please also tell me if the issue occurs if you're using the mouse on another USB port of your computer ?
As this might be a software conflict, please use this tool and provide the zip file it will create : https://help.corsair.com/hc/en-us/articles/4407362623117-How-do-I-use-Corsair-Windows-Reporter-Utility-


Second Response:

I'd also suggest verifying that the antivirus you're using does not have the gaming mode activate and that it is not blocking iCUE.


Third Response:

Could you please use this tool provided by Microsoft to ensure your PC is not missing any important file : 


Fourth Response:

I know you've tried on another computer but have you tried on another USB port or via a HUB on your new computer ?
Also, please ensure your BIOS, chipset, and motherboard drivers are up-to-date.

Edited by NemoSW
clarify instructions
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...