Jump to content
Corsair Community

iCUE not Detecting H150i Capellix


Recommended Posts

Hi All,

I’ve tried reading up on this but I’m at a loss now.

Basically my H150i Capellix isn’t being detected by iCUE. It was working fine, and then it just stopped. Pump and fans still spin, but no control over speeds or lighting. Can’t seem to find the device in device manager either now. I had this problem before and then it went away and was fine for a month, nothing changed or moved then it’s gone off again. updated BIOS, no luck. I’ve tried changing between the 2 USB inputs on the board, no luck. I’ve tried restarting, turning PC off and switching power off at wall, no luck. I even bought a Corsair internal powered USB hub to try and connected that up and no luck. Also worth noting my Lighting Node isn’t working at the same time as this either. Guessing it’s all linked, but no clue what the issue is.

Everything is pretty much new as it was a new build in June last year:

System Specs:

Windows 11 Pro

Motherboard ROG B550F with latest stable BIOS (2806).

Corsair Hx1000 PSU

32gb Corsair Dominator Platinum 3200mhz

1.5TB Crucial P5 Plus

ROG 3090

H150i CPU Cooler

Ryzen 5 5600X

Corsair 5000X

10 RGB Corsair fans - 4 into Commander, 6 into PWM controller than came with case which is then connected to the Commander and the commander connected to USB on MB

Lightning node that comes with case has the same 6 that are in PWM connected to it, this does not show up either.


Thanks in advance for any help.


Kind regards,





Edited by Seminole81
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...