Jump to content
Corsair Community

Alienware M15 R7 will not recognize Corsair Vengence DDR 5 Sodimm 32G 4800

Recommended Posts

So I bought 2 Vengeance DDR5 32GB 4800 modules to upgrade to 64GB for the factory installed 16GB (2  8GB DDR 5  Sodimm), and tried installing them in my alienware M15R7. I followed the directions for removing the battery and pressing the power button for 30 seconds to drain the power. After installing the new corsair ram, the laptop will not boot up and gives me the indicator for invalid memory (2 red, 5 Blue light sequence. I replace the old memory and the laptop booted fine.

Any help or feedback would be great.

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...

I`m having the same problem here. try everything possible. Nothing works. 

Was following this link, and looks like some people got it fixed by following those steps. (Didn't work for me)


Link to comment
Share on other sites

11 hours ago, Corsair Jagtech said:

Please do try one stick at a time after resetting the BIOS VIA battery method. If the issue persist I do recommend submitting a ticket here and possibly even reaching out to Dell about this.

Already tried with just one corsair stick, with both corsair, with one dells original plus one corsair.. Nothing works.

The question here, is why this ram memory is listed on your site as compatible for Alienware m15 r7.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...