Jump to content
Corsair Community

Corsair's own K57 firmware updates keep bricking USB receivers

Recommended Posts

What a complete farce I am going through.  

My Ironclaw mouse and K57 keyboard were both working fine on Windows 10. I then update to Windows 11, and both continued to work ABSOLUTELY FINE wirelessly - even though icue kept on saying there are firmware updates available. I ignored these updates for 2 weeks.

After 2 weeks has passed I decided to carry out the firmware updates, as I was getting sick of iCue telling me to update every day.  The ironclaw mouse completed the updates with no issue, after connecting the mouse via USB AND leaving the USB receiver plugged in as the instructions say.

On performing EXACTLY THE SAME ROUTINE with the K57 keyboard, the update just stopped halfway through and never completed. Icue had to be forcible closed using task manager. The keyboard then had to be "reset" as it didn't function at all. Since this moment the keyboard will now not pair with its USB receiver and can no longer be used wirelessly. As soon as you plug in a USB cable it works, and it again prompts that firmware is available v5.0.188. When trying to perform the update again it tells me to "Ensure that the USB Wireless Receiver is inserted into your system" - IT IS! I have inserted the receiver into every available USB port on my PC - this message does not go away. I have disconnected ALL other USB devices from my PC (apart from ironclaw mouse) - this message does not go away. The receiver is NOT being connected via a USB hub, it is direct to the PC.

I stopped Asus Armoury Crate background service and paused antivirus as suggested, makes no difference. And if either of those things were the cause then I would have expected the ironclaw mouse firmware update to also have failed, but as stated it did not.

I completely uninstalled icue, restarted, and reinstalled icue, made no difference.

I tried using just the ironclaw USB receiver and slipstream to connect to both devices - it says it was successful, yet only the mouse works. I've tried using the K57 USB receiver to connect to both devices - it says it was successful, but again no, only the mouse works wirelessly and not the keyboard.

If I have both USB receivers plugged in now (like I used to) the ironclaw mouse is showing twice, once as connected, once as disconnected.

When clicking on the skip button on trying to update firmware, where the message says "press skip if you want to update the K57 RGB WIRELESS only or cancel to stop the update process", after a few seconds the update process disappears, the keyboard disappears from icure, and the keyboard needs resetting again for it to work (see 3rd screenshot).

I have tried re-pairing and updating firmware for my K57 keyboard on a separate laptop that I installed icue to - the problem is exactly the same as on my main PC.

So quite simply, after the failed firmware update on my K57, I now have both of my wireless USB receivers (one for K57, one for Ironclaw mouse) showing as paired with my ironclaw mouse.

No matter what I try, the K57 receiver is no longer communicating with the keyboard, meaning I cannot pair with the keyboard, and also meaning that I cannot update the keyboard's firmware. It feels like when attempting to setup the one USB receiver, through Slipstream, to pair both devices has caused this.

So in summary:

  • The K57 keyboard will not communicate with its USB dongle
  • As soon as the K57 keyboard is plugged in via USB cable it works, but prompts a firmware update
  • The firmware update cannot be done - as the keyboard does not find it's dongle
  • Repairing the keyboard does not work - as the keyboard does not find it's dongle
  • There is no option to restore 1:1 pairing under the dongle device settings
  • The dongle is PERSISTENTLY stuck paired to my Ironclaw mouse

Fast forward to now (2 weeks later), a NEW K57 USB receiver has been shipped to me via RMA from Hong Kong to the UK. I plug it in along with with keyboard being plugged in via USB cable, and iCue pops up with 2 firmware updates, one for the receiver itself, one for the K57 keyboard (the one that has been the problem one all along).  The USB receiver firmware updates fine, and the pairing process successfully showed the receiver now paired with the K57 keyboard - HOORAY I thought, finally my keyboard can be used wirelessly again... Nope, still wouldn't operate without being connected via USB cable.

Ok then, must be this K57 keyboard firmware stopping it, let's try and update it now that we have a successfully paired USB receiver, it should work right....  Wrong, I start the firmware update process and it never completes just like before.  I leave the update process over an hour on the off chance it's taking its time, knowing forewell it will never complete.  After an hour I have to admit defeat and end the iCue process and reboot.  The new USB receiver is then UNPAIRED from the K57 keyboard we're back to EXACTLY THE SAME SITUATION AGAIN!  As a last resort I try to connect it using slipstream, by also plugging the ironclaw mouse in via USB cable, along with the keyboard, and then click go.  Surprise surprise It said it was "successful", but no, I now have yet another dongle paired with the mouse only and not the keyboard.

I'm no IT luddite, I work in software, I've built countless PC's over the past 20+ years, this is beyond a joke and some gross defect somewhere within iCue/the latest K57 v. 5.0.188 firmware update.  

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

I am having the exact same issue, both Keyboard as Dongle are bricked and everything was working flawlessly before the upgrade. I cannot believe this from Corsair, how can there not be a repair tool or something available or even a factory reset to the original version.

Link to comment
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...