Jump to content
Corsair Community

iCue Lighting Node Core stopped working

Go to solution Solved by c-attack,

Recommended Posts

I've recently gotten my hands on some new iCUE SP fans, 2x140 mm and 4x120 mm. I installed them all in my case, and hooked them up to the lighting node core that came with the 140mm ones. My motherboard, a ROG B450-F Gaming II has just one USB output (that, according to the website, supports at least 2 usb outputs). So I got a USB splitter, and attached the core to one output and my H100I Pro XT water pump to the other. For a while both of them worked just fine this way. Recently though, the lighting node core stopped showing up in iCue. Some googling led me to try plugging it into the motherboard directly, and it showed up again. This meant for a while I had to choose my fan lighting over my pump lighting. Unfortunate. Now though, when the lighting node core shows up it won't even light up my fans. All 6 of them show up in iCue, and even display as if they were working on the software. They simply do not light up in person, even when connected direct to the motherboard.

Is there a reason it stopped working, and how would I go about fixing it? Or do I just have a busted Lighting Node? Ideally I would like to control both of my iCue products without spending anymore money. My entire system and setup is composed of Corsair products, so as you can imagine this is a big bummer for me.



1.) pump and lighting node plugged into the usb splitter, icue doesn't recognize the node at all anymore (one fan lights up the wrong color for some reason?) 6216F7B7-5439-40B9-A132-028EC48C63FC.thumb.jpeg.d38b46cd2cc28a5e03cce81aeaf192b9.jpeg

2.) pump unplugged to utilize the lighting node, shown in icue


3.) fans display colors according to their mural placement, should be working just fine


4.) Here is my pc before I bought a usb splitter, I can assure you both the fans and the pump worked at one point. Unfortunately I don't have any photos from when that was. 1F20A7E6-4CF1-41D1-8C19-43E5F6A11566.thumb.jpeg.7e632a16cc5674cfe2c1b11e96b575cb.jpeg

I'd really love to go back to the cool, but ever-so-temporary look!




(yes I got the icue nexus. I think it's kinda neat)

Link to comment
Share on other sites

  • Solution

1. USB connections - Certain x570/B550 boards and their predecessor x470/B450 models with bios updates to make them compatible with the subsequent cpu generation have trouble with multiple devices stacked in the same usb line. This was a problem from the moment those boards came out and most users need a powered USB hub to help manage multiple connections. These are inexpensive but have a SATA connector for power and a circuit board to manage typically 4-5 usb 2 ports. The traditional unpowered “splitter” does not provide a steady connection and may cause frequent erratic connection. 

2. “SP fans” -> You need to be really careful with Corsair names. The SP-RGB fan came out in 2016 and is discontinued. You don’t have that so make sure your SP-Pro or SP-Elite is set to “8 LED fan series” in Lighting Setup. If you set it to SP fan it may not light or show a strange white pattern. 

Other possibilities involve a defect in the lighting chain. The Lighting Node Core is serial so if LED #6 fails on fan #1, then the lighting will come to a stop right there. A partial signal can cause weird flickering effects, but that does not seem to be the case here. Assuming top right fan is “#1” on the LNCore, swap it with fan 4 and see if lighting return to the first three fans. 

The usb issue is not related to the lighting. Even if you unplug the sun for the LNCore, the SATA power will produce the hardware lighting effect across all fans. You cannot selectively apply lighting in HW Mode so that eliminates usb connectivity as a cause for this. Corsair fans should always have lighting in HW Mode unless you save a static black pattern to the controller. 

Link to comment
Share on other sites

Thanks for the help with identifying the fans in the software! Seems to have made the unit recognize them again, and now they're working as expected. Seems a little misleading to have them named so similarly.

As for the powered USB hub, would something like the NZXT AC-IUSBH-M3 work? It seems to be the only product I can find related to what you're describing. If that's the case, is there a cheaper way? I've already spent money to try and fix this problem, shelling out another $30 just to control my pump lighting would be pretty unfortunate.

You've been super helpful, thank you!

Link to comment
Share on other sites

Yes, the NZXT one has been a mainstay all along and lots of people use it.  Corsair now sells one as well and there are others out there, mostly with unfamiliar names.  All of them should work. 


An alternative solution would be to use a USB 2 9 pin internal to USB A adapter to connect to the rear IO panel.  You would nee to thread it out the back of the case but this should work and is going to be a bit cheaper than the USB hub.  


A third option would be a USB 3 -> USB 2 internal conversion cable.  This would burn an internal USB 3 port for the pump, but if you are not currently using it then that may not matter.  Also should be a bit cheaper than a USB hub at the expense of less utility.  Almost any internal device you connect will need a USB port these days.  

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...