Jump to content
Corsair Community

H150i Elite red flashing LEDs - Fans non-responsive to iCue.

Go to solution Solved by Live4Kpop,

Recommended Posts

Hi all,

First a bit of backstory... I just recently rebuilt my system with a new motherboard, but here's what I was running before...

Previous system was an i7-10700K, Gigabyte Z490 Aorus Pro AX, DDR4, RTX 3080, EVGA 750 PSU, Corsair H100i Pro RGB cooler. This setup all worked fantastic.

I recently upgraded components...  i7-13700K, Gigabyte Z790 Aorus Elite AX, DDR5, Corsair RM1000e PSU... but, the H100i didn't seem to work properly. The fans were spinning, and iCue reported the RPM's of the fans and pump, but they would not respond to changes in temperature, so even as the CPU went under load, the fan and pump RPM remained the same and I would often hit 100C on the CPU. It wasn't bad enough to cause system instability, but the CPU was definitely throttling, so I knew the cooler wasn't doing what it should.

Yesterday, I picked up a new H150i Elite and installed it, but now the problem is even WORSE. The pump initially showed RGB colors for maybe 30 seconds, but then started flashing red, and the CPU temps kept climbing steadily until hitting 90~100C at idle. The fans were running, but really slowly, and iCue reported barely 500 RPM on the fans and the pump, and just like the H100i, they did not respond to changes in temperature or my fan settings changes in iCue.

I am running the latest version of iCue, and it says that the cooler firmware is the latest version. I've tried it both with and without the USB plugged into the USB header and fan tach wire plugged into the CPU_FAN header (also the CPU_OPT header) with no change in behavior whatsoever. Considering that the H100i and the new H150i both exhibit similar behavior, it makes me wonder if the motherboard is the cause, but if they operate the same without any wired connection to the motherboard, that would rule that out, wouldn't it?

Also, I hear the "USB connect/disconnect" sounds in Windows randomly, and iCue subsequently loses/acquires connection to the cooler at the same time. (When the USB header is plugged into the motherboard.) I've tried all the USB headers on the motherboard with no change.

BTW, I tried a trick that someone else posted about, where they unplugged the SATA connector and plugged it back in while the system was powered and iCue was open. This actually worked for about 20 minutes, and the CPU temps were stable-ish at about 40C during idle, and fan and pump RPM did change, although not much, and when the CPU went under load, it still rapidly hit 100C within seconds. After this short period of "sort of working", it went back to flashing red, the RPMs ran low, and the random USB connect/disconnect sounds again.

I'm going to take the H150i back to Microcenter and exchange it, but I fear that the same thing will happen... anyone have any supporting information that might help me decide if my fears are unfounded? I see a lot of posts on this forum and other forums all over the internet about this same (or very similar) issue with the H150i and Capellix, so I feel like I'm rolling the dice getting a second one just like it, although many of the people that have had the same issue reported that the replacement unit they received work perfectly.

Any guidance will be appreciated!! 🙂

Edited by Live4Kpop
Link to comment
Share on other sites

Seems I can't edit my post after a period of time, so I just want to add a small detail, when I first powered up the new components with the H100i, the RGB on the pump flickered red... NOT flashing... flickered, kind of like a flashlight that was struggling to stay on with just the last bit of battery life... for a minute or so then stopped working entirely. No flashing red, no flickering, no RGB pattern, nothing. Fried? Who knows.

Link to comment
Share on other sites

Well, I got a second new H150i from Microcenter, and I guess that was a mistake, because it's doing the EXACT same thing as the first one. OMFG.

Surely the failure rate on these can't be so bad that I actually get two DOA's in a row, can it?? So NOW what should I check??? The PSU?? The mobo??? In 30 years of building PC's, I've never seen anything that made so little sense. 😩

Link to comment
Share on other sites

  • Solution

Wow, okay, I fixed it.

Yes, I really have been building PC's for 30 years, and I work in IT, but anyone can make a mistake, regardless of experience. So, the short version is that during my initial build, I came up short on SATA power connections, so I borrowed one from another PSU, forgetting that it was a different brand (EVGA) and their 6-pin SATA power sockets have a different pin-out arrangement than Corsair does. You can figure out the rest, I'm sure.

I swapped that borrowed EVGA cable for a Corsair cable, and daebak! Powered on, everything works. EVERYTHING. RGB, fans, pump, iCue... temps are awesome, system is stable, and I'm exhausted. Lesson learned.

Thank you, and good night. 😜

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...