Jump to content
Corsair Community

Virtuoso SE not connecting

Recommended Posts

Headset was working fine left to go do some things and it went to sleep when i came back my EQ wasnt working ive had this problem before so i uninstalled and reinstalled icue that usually works but this time it made my headset unusable it wont connect with the wire or through wireless its basically a 200$ paper weight. can we stop adding things to icue and fix it because this is terrible

Link to comment
Share on other sites

I have the same issue.

My iCUE equalizer wasn't working today.  I saw there was an update available so I updated to v.4.33.138 (latest version) and the equalizer still does nothing.  I tried restarting, exiting iCUE and reopening, checked audio settings all set to my Virtuoso SE, tried different usb ports, nothing worked.  

It was working great, but now everything sounds like lo-fi and while its not a paper weight yet, I certainly don't want to clean install considering SeanN45's report above.

Hot Fix Please!

Link to comment
Share on other sites

  • Corsair Employees

Right click on the audio icon in the Windows taskbar and then run the troubleshooter.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...